Closed Bug 1175633 Opened 5 years ago Closed 4 years ago

test_DurationUpdated.html can fail intermittently when sourceended gets fired before the second durationchange

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bholley, Unassigned)

References

(Blocks 1 open bug)

Details

I just noticed this happening locally, and wanted to get a bug on file since I was able to reproduce it.

The basic problem is that our current MSE implementation can fire sourceended before durationchange, causing test_DurationUpdated.html to fail. I'm not sure if this is a bug in our test or our implementation.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.