[e10s] 3-way WaitForMessage hang clicking on the test plugin

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(e10sm7+, firefox40 affected, firefox41 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8623872 [details]
test case

Pretty sure this is a regression since I've been working with these test cases regularly for months now and this is the first I've seen of this.

STR:

1) open the test case and let the green test plugin load
2) click on the green plugin window

result: deadlock

Here's the weird thing: the content process is caught up in WaitForMessage as well which should not happen since that thread should not have an event queue that's bound to the other processes.
(Assignee)

Comment 1

3 years ago
Tracy, can you reproduce this?
Flags: needinfo?(twalker)
(Assignee)

Updated

3 years ago
Assignee: nobody → jmathies
With the testcase, I get a grey plugin window with the lego piece "A plugin is needed to display this content."  Clicking on it does nothing.
Flags: needinfo?(twalker)
(Assignee)

Comment 3

3 years ago
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #2)
> With the testcase, I get a grey plugin window with the lego piece "A plugin
> is needed to display this content."  Clicking on it does nothing.

You need the to get the test plugin installed. The test plugin is available in local windows builds and in our test package zips the test slaves use.
(Assignee)

Comment 4

3 years ago
I did spot checks back to 01-01 and was able to reproduce so I guess this has been around for a while.
(Assignee)

Updated

3 years ago
status-firefox40: --- → affected
tracking-e10s: --- → m7+
(Assignee)

Comment 5

3 years ago
Note to self, if you ever copy a debug build of the test plugin over to your profile directory, remember to remove it after you're through testing.

I had a copy of the test plugin with a 45 second hang on left click installed. :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.