firefox for mac does not show the private browsing "mask logo" or any other indication in the browser tab. functionality is still good though.

RESOLVED DUPLICATE of bug 906117

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 906117
3 years ago
3 years ago

People

(Reporter: atad1234, Unassigned)

Tracking

({in-triage})

38 Branch
in-triage
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

opened private window


Actual results:

there is no indication that it is private browsing mode. 


Expected results:

ourple mask icon in the top right corner

Comment 1

3 years ago
Have you tried if you see this issue in a new profile, too? You can find details on how to create a new profile (without changing anything in your regular profile!) at https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles .

Have you tried if you see this issue in Firefox's safe mode, too? You can restart Firefox into safe mode by using the 'Restart Firefox with add-ons disabled' entry in the 'Help' menu. This will also disable graphics hardware acceleration and some JS engine optimizations, not just extensions and plugins. See https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode .
Flags: needinfo?(atad1234)
Keywords: in-triage

Updated

3 years ago
Group: core-security

Updated

3 years ago
Component: Untriaged → Private Browsing

Comment 2

3 years ago
Launching Firefox with the private browsing flag set on the command line: 

Windows:
   firefox.exe /private
Linux:
   firefox -private

brings up Firefox in private browsing mode, but without the purple mask icon in the tab bar for all
private browsing pages. The default "You're browsing privately" page has a mask icon in its tab, probably a favicon, but other pages do not.  If you launch Firefox with, for example

   firefox.exe http://www.example.com /private
or
   firefox http://www.example.com -private

Firefox comes up in private browsing mode, with no visible indication of the fact.
  
If Firefox is started with a Windows startup item with the /private flag, (not unusual for public-access computers), this situation can arise.

(Because private browsing disables many add-ons, I spent several days chasing a problem reported with one of my add-ons before discovering this.  The reporting user didn't know they were in private browsing mode.)

Comment 3

3 years ago
Per comment #2, marking this as a duplicate of the same issue as filed earlier.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(atad1234)
Resolution: --- → DUPLICATE
Duplicate of bug: 906117
You need to log in before you can comment on or make changes to this bug.