Closed Bug 1175824 Opened 5 years ago Closed 5 years ago

Allow to style the spin button of number inputs

Categories

(Core :: Layout: Form Controls, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 978320

People

(Reporter: sebo, Unassigned)

References

Details

User Story

Web designer wants to adjust the layout of the form controls to the layout of a website.
It should be possible to style the two spin buttons of an <input type="number"> via CSS.

At least you should be able to change their background and the color of the arrows, though further control about their layout would be better.

Sebastian
I don't think we should implement any more of this kind of feature before
the CSSWG has come up with a spec which UA vendors agrees to implement.

It's probably better to discuss use cases and requirements on www-style@w3.org

fantasai started a thread on this topic here:
https://lists.w3.org/Archives/Public/www-style/2015Jan/0490.html
(In reply to Mats Palmgren (:mats) from comment #1)
> I don't think we should implement any more of this kind of feature before
> the CSSWG has come up with a spec which UA vendors agrees to implement.

Actually I agree with this. I created this issue more to split this from bug 1108469, which I consider rather a layout bug while this is an enhancement.

Sebastian
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 978320
You need to log in before you can comment on or make changes to this bug.