Closed Bug 1175833 Opened 5 years ago Closed 4 years ago

Buttons from conversation window are gone after adding/editing context

Categories

(Hello (Loop) :: Client, defect, P1, major)

defect
Points:
1

Tracking

(firefox40 verified, firefox41+ unaffected, firefox42 unaffected)

VERIFIED FIXED
mozilla40
Iteration:
42.2 - Jul 27
Tracking Status
firefox40 --- verified
firefox41 + unaffected
firefox42 --- unaffected

People

(Reporter: bogdan_maris, Assigned: mikedeboer)

References

Details

(Keywords: regression, Whiteboard: [context])

Attachments

(2 files)

Attached image Gif showing the issue
Affected builds:
- Latest Nightly

Unaffected builds:
- Latest Aurora

Affected OS`s:
- Windows 7 64-bit
- Mac OS X 10.9.5
- Ubuntu 14.04 32-bit

STR:
1. Start Firefox
2. Visit https://www.mozilla.org/en-US/firefox/hello/
3. Click Hello icon
4. Start a conversation
5. From conversation window click 'Add some context'
6. Click Save

Alternative STR:
1. Start Firefox
2. Visit https://www.mozilla.org/en-US/firefox/hello/
3. Click Hello icon
4. Start a conversation with 'Let`s talk about' ticked
5. From conversation window enter context edit screen
6. Click Save

Expected results: Edit screen is closed and buttons are still visible.

Actual results: Edit screen is closed but buttons are gone from conversation window.

Notes:
- Gif showing the isssue attached.
- This is a regression that was introduced with bug 1170627.
Mike, it looks like this may have been caused by bug 1170627.
Flags: needinfo?(mdeboer)
Keywords: regression
This issue does not reproduce anymore on latest Nightly 42.0a1, probably fixed in bug 1171940.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(mdeboer)
Resolution: --- → WORKSFORME
Bogdan, is this reproducible on firefox 40? Can you please update the status-firefox40 flag?
Flags: needinfo?(bogdan.maris)
Yes, this is still reproducible on Firefox 40 across platforms.
Flags: needinfo?(bogdan.maris)
Liz, you were absolutely right, this IS caused by bug bug 1170627. You saved me an hour or two debugging! Thank you :-)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Assignee: nobody → mdeboer
Status: REOPENED → ASSIGNED
Simple fix, it turns out!
Attachment #8637184 - Flags: review?(standard8)
Comment on attachment 8637184 [details] [diff] [review]
Patch v1: propagate editMode state change up the components tree

Looks good, r=Standard8
Attachment #8637184 - Flags: review?(standard8) → review+
Iteration: --- → 42.2 - Jul 27
Points: --- → 1
Priority: -- → P1
Blocks: 1170627
Comment on attachment 8637184 [details] [diff] [review]
Patch v1: propagate editMode state change up the components tree

Approval Request Comment
[Feature/regressing bug #]: bug 1170627
[User impact if declined]: User will not see the share action buttons in the invitation overlay when he/ she just saved the context attached to a conversation.
[Describe test coverage new/current, TreeHerder]: none, pushed to try (see comment 8). When green, we're good to go.
[Risks and why]: minor, 3-line change.
[String/UUID change made/needed]: n/a.
Attachment #8637184 - Flags: approval-mozilla-beta?
Comment on attachment 8637184 [details] [diff] [review]
Patch v1: propagate editMode state change up the components tree

From the try push it looks like we're gtg. Beta+
Attachment #8637184 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Flags: qe-verify+
Verified fixed on 40.0b7 (Build ID: 20150723165742), across platforms [1].

[1] Windows 7 64-bit, Windows 10 32-bit, Ubuntu 14.04 32-bit and Mac OS X 10.10.4
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.