Support High Bit Depth VP9 Video

RESOLVED DUPLICATE of bug 1215089

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED DUPLICATE of bug 1215089
3 years ago
6 months ago

People

(Reporter: Jan Gerber, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 affected, firefox47 affected)

Details

(Reporter)

Description

3 years ago
VP9 has support for more than 8 bit streams with 4:2:0 sub-sampling, Firefox should eventually support videos with higher bit depth or other sub-sampling:

Profile 0 covers 8 bit streams with 4:2:0 sub-sampling
Profile 1 covers 8 bit streams with 4:4:4, 4:2:2 and 4:4:0 sub-sampling
Profile 2 covers 10/12 bit streams with 4:2:0 sub-sampling
Profile 3 covers 10/12 bit streams with 4:4:4, 4:2:2 and 4:4:0 sub-sampling
Component: Audio/Video → WebRTC
This is primarily for Playback usage
Component: WebRTC → Audio/Video: Playback
Jean-Yves, how much work would it be to add high bit depth support with ffvp9?
status-firefox47: --- → affected
Flags: needinfo?(jyavenard)
Does YouTube have any high bit depth content?
(In reply to Chris Peterson [:cpeterson] from comment #2)
> Jean-Yves, how much work would it be to add high bit depth support with
> ffvp9?

2 lines of code.

The issue isn't with ffvp9 (or any other decoders) but supporting 10 bits and higher images in the compositor.
See bug 1239510
Depends on: 1239510
Flags: needinfo?(jyavenard)
Priority: -- → P3

Updated

a year ago
Blocks: 1215089
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1215089
You need to log in before you can comment on or make changes to this bug.