Closed Bug 1175902 Opened 5 years ago Closed 5 years ago

Empty screenshot box should be hidden in about:addons

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla42
Tracking Status
firefox41 --- affected
firefox42 --- verified

People

(Reporter: vasilica.mihasca, Assigned: Paenglab)

References

Details

Attachments

(1 file, 1 obsolete file)

Reproducible on: Firefox 40.0a2 and Firefox 41.0a1 across all platforms

STR
1.Launch Firefox with clean profile.
2.Navigate to about:addons.
3.Install a theme.
4.Select Appearance from the left menu.
4.Click on “More” link that correspond to a theme.

AR
Unresponsive check box is displayed in theme details tab, but anyway it is useless in this context.

Additional notes:
- This issue is reproducible on Firefox 40.0a2 (2015-06-17/18) and Firefox 41.0a1 (2015-06-17/18) under Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5
- I am attaching screenshots:
           http://i.imgur.com/bN2Ei11.jpg
           http://i.imgur.com/N81wMQx.jpg
This isn't a checkbox, it's a box used to display the screenshots. Although I agree it is misleading when empty.
Summary: Unresponsive theme check box in about:addons → Empty screenshot box should be hidden in about:addons
Attached image conn-not-secure.svg (obsolete) —
My JS skills are too low so I can do this only with CSS. The drawback of this solution is we have no more a 10px gap between the image and the box-shadow.
Attachment #8626932 - Flags: review?(dtownsend)
Comment on attachment 8626932 [details]
conn-not-secure.svg

Seems like the wrong patch has been attached here.
Flags: needinfo?(richard.marti)
Attachment #8626932 - Flags: review?(dtownsend)
Attached patch Bug1175902.patchSplinter Review
Yes, sorry. Now the correct patch.
Attachment #8626932 - Attachment is obsolete: true
Flags: needinfo?(richard.marti)
Attachment #8626981 - Flags: review?(dtownsend)
Comment on attachment 8626981 [details] [diff] [review]
Bug1175902.patch

Review of attachment 8626981 [details] [diff] [review]:
-----------------------------------------------------------------

Let's take it for now. If someone wants to do the JS way later then fine.
Attachment #8626981 - Flags: review?(dtownsend) → review+
Keywords: checkin-needed
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: qe-verify+
https://hg.mozilla.org/mozilla-central/rev/cabd735fde27
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
QA Contact: vasilica.mihasca
I was able to reproduce this issue on Firefox 41.0a1 (2015-06-18) under Windows 7 64-bit.
Verified fixed on latest Firefox 42.0a1 (2015-07-09) under Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac Os X 10.9.5.

I noticed that “None” word is very confusing in this situation http://i.imgur.com/LMNgawn.jpg.
What do you think Tim? Is this word necessary to be displayed for a theme without description?
Status: RESOLVED → VERIFIED
Flags: needinfo?(ntim.bugs)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #8)
> I was able to reproduce this issue on Firefox 41.0a1 (2015-06-18) under
> Windows 7 64-bit.
> Verified fixed on latest Firefox 42.0a1 (2015-07-09) under Windows 7 64-bit,
> Ubuntu 14.04 32-bit and Mac Os X 10.9.5.
> 
> I noticed that “None” word is very confusing in this situation
> http://i.imgur.com/LMNgawn.jpg.
> What do you think Tim? Is this word necessary to be displayed for a theme
> without description?

Feels weird to me too. We should probably remove it. Can you file a new bug please ? Thanks !
Flags: needinfo?(ntim.bugs)
(In reply to Tim Nguyen [:ntim] (away 11-14 July) from comment #9)

> Feels weird to me too. We should probably remove it. Can you file a new bug
> please ? Thanks !

Filed Bug 1182473
You need to log in before you can comment on or make changes to this bug.