mach build-docs fails due to reading test moz.build files

RESOLVED WONTFIX

Status

()

Core
Build Config
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8624289 [details]
log

Comment 1

3 years ago
I'm unable to reproduce this.

We're supposed to ignore the the test directories when scanning moz.build files as part of building the docs.

Do you have any symlinks or uppercase letters in your srcdir/objdir paths? Does a clobber fix things?
Component: mach → Build Config
Flags: needinfo?(bgirard)
Summary: mach build-docs fails → mach build-docs fails due to reading test moz.build files
(Reporter)

Comment 2

3 years ago
No, but I do have my objdir live outside my srcdir which I guess is unusual:

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../builds/obj-ff-64gdb

My structure is:
mozilla-central
- tree
- builds/obj-ff-64gdb (based off .mozconfig64gdb)
- builds/obj-ff-64opt (based off .mozconfig64opt)

Perhaps that's the problem?
Flags: needinfo?(bgirard) → needinfo?(gps)
(Reporter)

Comment 3

3 years ago
Ohh interesting. Looks like I somehow accumulated a nested mozilla-central checkout inside my main mozilla tree at a few years back and never noticed.

Looks like this is one of the few commands to be sensitive to that. IMO this is still a bug but probably less important.

Comment 4

3 years ago
It's not a bug: it's how moz.build reading works in filesystem traversal mode. We simply walk the filesystem looking for moz.build files.

Yes, we could integrate with VCS to grab the files list or we could ignore subrepos (.hg or .git dirs). But since you are the first person to hit this, I'm going to say this is well below our threshold for problems to deal with.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gps)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.