Creating a group on the device from collections takes at least 2 minutes

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Homescreen
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [spark])

Attachments

(1 attachment)

Created attachment 8624553 [details]
logcat.txt

1. go to homescreen
2. long tap on a blank space
3. select add smart collection
4. select movies ( if you actually see a listing)

Expected: it just creates the group
Actual: you have to wait 2 minutes
Whiteboard: [spark]

Comment 2

3 years ago
I've certainly never seen this on 2.2, so probably a regression - let's get a window.
Keywords: regression, regressionwindow-wanted
I cannot reliably reproduce this issue.

1st attempt adding Movies: ~5 seconds
2nd attempt adding all the rest of smart collections: ~30 seconds. Then I deleted all collections except the default 3 and
3rd attempt adding all smart collections: 37 seconds (this time I used stopwatch). Then I deleted all except default 3
4th attempt adding Movies: 65 seconds - I counted this as a repro
5th attempt adding Movies: 7 seconds

Due to inability to reliably reproduce, removing regression and window wanted keywords. This seems like a server issue, because on Flame 2.2 I even have trouble bringing up a list of collections for me to add. It told me I had no internet connection when I did.

Device: Flame 3.0
BuildID: 20150619010205
Gaia: a0df9c367a68764bdcf2e2e1c4d27f0d6ee165b8
Gecko: 2694ff2ace6a
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Device: Flame 2.2
BuildID: 20150619002501
Gaia: 1c33072e33c279c8aa5cb5e4a3e4da6af6cd818b
Gecko: 5ad34a170633
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression, regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.