Backout Bug 1141548 because libmozalloc.so is missing from comm-beta (39) SeaMonkey/Thunderbird builds

RESOLVED FIXED in Thunderbird 39.0

Status

MailNews Core
Build Config
--
blocker
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: adriank, Assigned: adriank)

Tracking

Thunderbird 39.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird39 wontfix, seamonkey2.35 unaffected, seamonkey2.36+ fixed, seamonkey2.37 unaffected, seamonkey2.38 unaffected)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Bug 1173683 did break the SeaMonkey builds from the current comm-beta: they won't start because of:
"libmozalloc.so: cannot open shared object file: No such file or directory"

Reversing and applying the patch from Bug 1141548 (attachment 8575314 [details] [diff] [review]) on comm-beta should fix this and make the builds usable again.

Updated

2 years ago
Blocks: 1141548

Updated

2 years ago
Summary: libmozalloc.so is missing from comm-beta (39) SeaMonkey builds → Backout Bug 1141548 because libmozalloc.so is missing from comm-beta (39) SeaMonkey builds
(Assignee)

Comment 1

2 years ago
Created attachment 8625448 [details] [diff] [review]
Patch v1
Attachment #8625448 - Flags: review?(Pidgeot18)

Comment 2

2 years ago
Affects Thunderbird comm-beta builds too.
https://treeherder.mozilla.org/#/jobs?repo=comm-beta
Assignee: nobody → akalla
Status: NEW → ASSIGNED
status-thunderbird39: --- → affected
tracking-thunderbird39: --- → ?
Summary: Backout Bug 1141548 because libmozalloc.so is missing from comm-beta (39) SeaMonkey builds → Backout Bug 1141548 because libmozalloc.so is missing from comm-beta (39) SeaMonkey/Thunderbird builds
(Assignee)

Comment 3

2 years ago
Tomorrow is merge day and this is still not fixed...

Updated

2 years ago
tracking-seamonkey2.36: --- → -

Updated

2 years ago
Blocks: 1181513

Updated

2 years ago
tracking-seamonkey2.36: - → +

Comment 4

2 years ago
Comment on attachment 8625448 [details] [diff] [review]
Patch v1

The reporter in Bug 1181513 says that the patch here fixes his build problem.
r=me a=me
Attachment #8625448 - Flags: review?(Pidgeot18) → review+

Comment 5

2 years ago
(In reply to Adrian Kalla [:adriank] from comment #3)
> Tomorrow is merge day and this is still not fixed..
a=me for check-in to comm-release39/seamonkey2.36/
For comm-esr38 please ask thunderbird/mailnews drivers
Keywords: checkin-needed

Comment 6

2 years ago
We did not do a Thunderbird 39 beta, and probably will never do it. I don't believe that Thunderbird needs this. Thunderbird 38/SeaMonkey 2.35 was unaffected. right?

Comment 7

2 years ago
(In reply to Kent James (:rkent) from comment #6)
> We did not do a Thunderbird 39 beta, and probably will never do it.
Got it. Thanks.
> I don't
> believe that Thunderbird needs this. Thunderbird 38/SeaMonkey 2.35 was
> unaffected. right?
Correct!

Comment 8

2 years ago
Pushed to comm-release [default branch]
http://hg.mozilla.org/releases/comm-release/rev/e4c53c8c6395
http://hg.mozilla.org/releases/comm-release/graph/e4c53c8c6395
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-seamonkey2.36: affected → fixed
status-thunderbird39: affected → wontfix
tracking-thunderbird39: ? → ---
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

2 years ago
Duplicate of this bug: 1181513
You need to log in before you can comment on or make changes to this bug.