[Build 22-24] Removing history item results in crash

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: stef, Assigned: fluffyemily)

Tracking

({crash})

unspecified
Other
iOS
crash

Firefox Tracking Flags

(fxios+)

Details

(Whiteboard: [stack needed])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
The browser crashes on iPhone 5s and iOS 8 when I go to history pane and try to remove an item.
I confirm. It does the same on iPhone 6, iOS 8.
Can't repro in current trunk. Anyone else?
Flags: needinfo?(sleroux)
Keywords: crash
Whiteboard: [stack needed]
tracking-fxios: --- → +
Not able to reproduce this on the 6 simulator or my iPhone 6 device.
Flags: needinfo?(sleroux)
I'm on build 21, not 22 so perhaps it has been resolved. I do not however have access to 22 yet so I can't confirm if this is true.
Duplicate of this bug: 1179911
(Assignee)

Comment 6

4 years ago
This has been resolved in current master
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

4 years ago
I can still reproduce this with TestFlight build 24.
Summary: [Build 22] Removing history item results in crash → [Build 22-24] Removing history item results in crash
(In reply to Stefan Plewako [:stef] from comment #7)
> I can still reproduce this with TestFlight build 24.

Is this with a reinstall too? Sounds like a broken state
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

4 years ago
(In reply to Aaron Train [:aaronmt] from comment #8)
> Is this with a reinstall too? Sounds like a broken state

The same thing if I force quit, remove and install it again. One strange thing is that I see my fxa logged in right after that in settings (not in on-boarding tour which displays as expected).
Stefan, could you pull a crash log off your device?

http://osxdaily.com/2012/08/07/get-crash-reports-logs-from-iphone-ipad/
Flags: needinfo?(splewako)
(In reply to Stefan Plewako [:stef] from comment #7)
> I can still reproduce this with TestFlight build 24.

I can also reproduce it in build 24. I only upgraded though. I did not do a full re-install.

I'll try to pull a crash log too when I have a few mins.
(Reporter)

Comment 12

4 years ago
Created attachment 8633021 [details]
Client_2015-07-13-223539_omron6.ips.beta
Flags: needinfo?(splewako)
st3fan, can you symbolicate that? Needs the dSYM from the TestFlight build.
Status: REOPENED → NEW
Flags: needinfo?(sarentz)
I just landed some changes in bug 1161630 to fix a crash I saw here (related to new rows being added to the bottom of the list).
I assume this is the one crash that you can see in the Organizer -> Crashes now.
Flags: needinfo?(sarentz)
We need a better STR for this bug. I am unable to repro this.
Flags: needinfo?(splewako)
Flags: needinfo?(adavis)
The one I saw would only happen if you had over 100 items in your history.
Created attachment 8633747 [details]
Client_2015-07-14-133720_MyPhone.crash

Here is my phone's crash report. Hope this helps.
Flags: needinfo?(adavis)
If the crash report isn't useful, I am in the Mountain View office and don't mind walking over to someone's desk to reproduce the bug in person.
(Assignee)

Updated

3 years ago
Assignee: nobody → etoop
Status: NEW → ASSIGNED
(Reporter)

Comment 20

3 years ago
(In reply to Wesley Johnston (:wesj) from comment #17)
> The one I saw would only happen if you had over 100 items in your history.

Just tested this and it seems to be the thing.

After logging out of fxa, force quiting app, removing from disk, freshly installing from TestFlight (iPhone 5s, iOS 8), I don't get crashes until opening over ~100 pages.
(Reporter)

Updated

3 years ago
Flags: needinfo?(splewako)
(Assignee)

Comment 21

3 years ago
Created attachment 8634757 [details] [review]
Pull request

This code is more simplistic than the previous version, but it definitely covers all eventualities which the other did not.
Attachment #8634757 - Flags: review?(sleroux)
Comment on attachment 8634757 [details] [review]
Pull request

Looks good!
Attachment #8634757 - Flags: review?(sleroux) → review+
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.