Closed Bug 11769 Opened 21 years ago Closed 9 years ago

Give filters capability to bounce back e-mail.

Categories

(MailNews Core :: Backend, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 11034

People

(Reporter: alecf, Unassigned)

References

Details

(Keywords: helpwanted)

from rjhall@earthling.net:
---
I suggest a bounce option in filters
  and for individual messages.  Ideally this would send the mail
  back to the sender showing that it was refused by the recipient.
  Of course it would become necessary to then dispose of any
  bounced message that comes back as undeliverable to the indicated
  sender.
---
We might have to lookup an RFC for how bounced messages are supposed to look, or
we may find that there's no spec for how a CLIENT is supposed to bounce
messages... but it would still be cool.
Target Milestone: M15
setting M15.  BTW, I really wish we had this feature.
Whiteboard: HELP WANTED
Bulk-resolving requests for enhancement as "later" to get them off the Seamonkey
bug tracking radar. Even though these bugs are not "open" in bugzilla, we
welcome fixes and improvements in these areas at any time. Mail/news RFEs
continue to be tracked on http://www.mozilla.org/mailnews/jobs.html
Reopen mail/news HELP WANTED bugs and reassign to nobody@mozilla.org
Depends on: 12916
I don't think this should be implemented if there's the possibility for infinite
bouncing.
Keywords: helpwanted
Summary: [HELP WANTED]Give filters capability to bounce e-mail. → Give filters capability to bounce e-mail.
Whiteboard: HELP WANTED
Target Milestone: M15
OS: Linux → All
QA Contact: lchiang → laurel
Hardware: PC → All
Maybe a header to indicate that mozilla has bounced it, and then drop it if it
comes back? (just my suggestion)
KMail, an open source mail client on KDE/Linux has this feature, both as an
action to be taken on specific emails and as a filter action.
Depends on: 109930
No longer depends on: 12916
Bug #12916 is not related to this bug. 12916 is about redirecting emails, like
forwarding except that the sender header is unchanged. Bug #109930 is about
forging a server bounce. Updating dependency to reflect...
Updating summary to indicate more clearly that this is about bouncing back to
original sender. Ther term "bounce" is used in many other clients to redirect
original email to another recipient.
Summary: Give filters capability to bounce e-mail. → Give filters capability to bounce back e-mail.
That would be nice, but the true factor is that 95% of all SPAM mail, if not
more, has a false return path which means the message would never be sendable
back to its original sender.  Sad but true.
You would avoid the bounced mail itself bouncing simply by setting its envelope
sender address to blank (in the SMTP conversation, quite independent of any of
the message headers). This is what MTAs do. If you View Source for a typical
delivery-failure report you will see

Return-Path: <>
From: MAILER-DAEMON@...

Return-Path is added at final delivery (i.e. by the last MTA) and captures the
empty envelope sender address.
I agree - this would be nice, regardless how possibly ineffective it might be. 
Now if only I knew enough about C++ to help (still learning right now).  I'll
throw a vote towards this - I haven't used most of the votes I've got anyways.

This feature is also in MailWasher.

Also, seeing as I've switched to Firebird and I'm not going to go back to
Mozilla  again, will this bug work for Thunderbird or should I post a
Thunderbird-specific bug?  (I checked the TB bugs, and right now this would be a
non-dup.)
Isn't this a dupe of bug 11034?
No.  See bug 11034 comment 24, if I'm not completely misunderstanding the situation.
I just tried out MailWasher and this and their learning filters are the things
which I think would be real great enhancements to Mozilla and Firebird.

Can't help in developing as I don't know C++ but would be happy in helping in
the testing.
Severity: normal → enhancement
Product: MailNews → Core
Bouncing after-the-fact (as opposed to refusing incoming mail) is a bad idea, it contributes more to the spam "problem" than to its solution: see http://www.spamcop.net/fom-serve/cache/329.html for a more detailed explanation.

I move this bug be WONTFIXed.
Filter on "Nobody_NScomTLD_20080620"
QA Contact: laurel → backend
Product: Core → MailNews Core
depends on bug 12916
dup of bug 11034
(In reply to comment #17)
> depends on bug 12916
> dup of bug 11034

I agee.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 11034
You need to log in before you can comment on or make changes to this bug.