missing symbols for B2G build

RESOLVED INVALID

Status

Socorro
Backend
RESOLVED INVALID
3 years ago
9 months ago

People

(Reporter: julienw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Created attachment 8625574 [details]
4a9410f4-2774-3a0b-75a2be64-17569523

Crash 4a9410f4-2774-3a0b-75a2be64-17569523 was submitted some days ago, but I can't find it on crash-stats.mozilla.com.

Wondering if it's been stuck in a queue somewhere...
(Reporter)

Comment 1

3 years ago
Created attachment 8625575 [details]
4a9410f4-2774-3a0b-75a2be64-17569523-submission
(Reporter)

Comment 2

3 years ago
Note that it was for a B2G Desktop crash.
(In reply to Julien Wajsberg [:julienw] from comment #0)
> Created attachment 8625574 [details]
> 4a9410f4-2774-3a0b-75a2be64-17569523
> 
> Crash 4a9410f4-2774-3a0b-75a2be64-17569523 was submitted some days ago, but
> I can't find it on crash-stats.mozilla.com.
> 
> Wondering if it's been stuck in a queue somewhere...

4a9410f4-2774-3a0b-75a2be64-17569523 was not generated by the crash collector (https://crash-stats.mozilla.com/report/index/4a9410f4-2774-3a0b-75a2be64-17569523 says "Invalid crash ID")

I see bp-adf01ce8-8534-4ee6-bc28-3b1382150618 in your attachment which does look like a valid crash ID... does that work for you?
Note that it looks like we're missing symbols (or were missing symbols) for that build at the time this was processed... I can help look into this if you need.
(Reporter)

Comment 5

3 years ago
OK, I think I was confused; I understand the crash id is not at all the UUID of the file name, then :)

About the symbols, I'm not sure how it works; my build is definitely coming from task cluster, and I thought those builds had the symbols in crash-stats automatically ;)
(In reply to Julien Wajsberg [:julienw] from comment #5)
> OK, I think I was confused; I understand the crash id is not at all the UUID
> of the file name, then :)
> 
> About the symbols, I'm not sure how it works; my build is definitely coming
> from task cluster, and I thought those builds had the symbols in crash-stats
> automatically ;)

They definitely should be! I'll try reprocessing them to see if they are there now, if not we'll need to ask taskcluster folks. We haven't had any symbol upload failures that I am aware of.
(In reply to Julien Wajsberg [:julienw] from comment #7)
> I reproduced my crash once more.
> 
> I used this build:
> https://queue.taskcluster.net/v1/task/o9uTjbkZQE-VSo3iXBDacw/artifacts/
> public/build/target.linux-x86_64.tar.bz2


Do you know how I could find the logs for this build?


> I got this crash:
> https://crash-stats.mozilla.com/report/index/e92051c5-4ffe-4265-93e7-
> c33ab2150624
> (still no stack trace)
Summary: Crash ID 4a9410f4-2774-3a0b-75a2be64-17569523 is not found on crash-stats.mozilla.com → missing symbols for B2G build
(Reporter)

Comment 9

3 years ago
I think this is:

https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/o9uTjbkZQE-VSo3iXBDacw/0/public/logs/live_backing.log

I'm adding it as attachment here because it might expire.
(Reporter)

Comment 10

3 years ago
Created attachment 8625978 [details]
live_backing.log
Attachment #8625574 - Attachment is obsolete: true
Attachment #8625575 - Attachment is obsolete: true
(In reply to Julien Wajsberg [:julienw] from comment #9)
> I think this is:
> 
> https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/o9uTjbkZQE-
> VSo3iXBDacw/0/public/logs/live_backing.log
> 
> I'm adding it as attachment here because it might expire.

I notice that this has set:

MOZ_AUTOMATION_UPLOAD_SYMBOLS=0

Ted, is it intentional that this build is not uploading symbols?
Flags: needinfo?(ted)
I talked to rhelmer in IRC, and I can confirm that B2G Desktop taskcluster do not upload symbols, we are going to fix that,
If you look at the log:
[1G[J[34m 0:07.93(B[m Adding client.mk options from /home/worker/workspace/gecko/b2g/config/mozconfigs/linux64_gecko/nightly:

that mozconfig:
https://dxr.mozilla.org/mozilla-central/source/b2g/config/mozconfigs/linux64_gecko/nightly#2
Flags: needinfo?(ted)

Comment 14

9 months ago
nah
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.