Closed Bug 1176984 Opened 6 years ago Closed 6 years ago

Build with Swift 2.0

Categories

(Firefox for iOS :: Build & Test, defect)

Other
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fxios 1.1+ ---

People

(Reporter: enedil, Assigned: fluffyemily)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

I followed the steps to build Firefox, but opened the Client.xcodeproj in Xcode 7 beta.


Actual results:

A lot of compilation errors. All of them are probably caused by the changes in Swift language since 2.0 version.


Expected results:

No errors.
Status: UNCONFIRMED → NEW
Component: General → Build & Test
Ever confirmed: true
I think we build with Swift 2 now (maybe?). Re-open if not.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
We don't support Swift 2 yet :( Reopening ticket
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Keywords: meta
Summary: Build fails with Xcode 7 beta and Swift 2 → [meta] Build with Swift 2.0
Assignee: nobody → etoop
Status: REOPENED → ASSIGNED
Attachment #8651811 - Attachment description: WIP → https://github.com/mozilla/firefox-ios/tree/swift-2.0
tracking-fxios: --- → ?
Keywords: meta
Summary: [meta] Build with Swift 2.0 → Build with Swift 2.0
1bd57e5
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.