[PFM]website crashes browser - http://www.mameman.it/

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Kervin, Assigned: serge (gone))

Tracking

({crash})

Trunk
mozilla1.1alpha
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
http://www.mameman.it/ crashes mozilla.
   
[mozilla@bashful mozilla]$ mozsysinfo 
#!/bin/sh -xv
# System information for mozilla bug reports.

cat ~/mozilla/config/build_number
+ cat /home/mozilla/mozilla/config/build_number
2001122501
cat ~/mozilla/.mozconfig
+ cat /home/mozilla/mozilla/.mozconfig
ac_add_options --prefix=/usr/local/mozilla
ac_add_options --enable-extensions=default,irc,xmlterm
ac_add_options --enable-leaky
ac_add_options --enable-jprof
ac_add_options --enable-xpctools
ac_add_options --enable-optimize=-O2
ac_add_options --enable-crypto
ac_add_options --disable-strip
cat /etc/redhat-release
+ cat /etc/redhat-release
Red Hat Linux release 7.2 (Enigma)
uname -a
+ uname -a
Linux bashful 2.4.7-10 #1 Thu Sep 6 17:27:27 EDT 2001 i686 unknown
gcc -v
+ gcc -v
Reading specs from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.0.2/specs
Configured with: /tmp/gcc-3.0.2/configure --prefix=/usr
Thread model: single
gcc version 3.0.2
ld -v
+ ld -v
GNU ld version 2.11.90.0.8 (with BFD 2.11.90.0.8)
[mozilla@bashful mozilla]$
(Reporter)

Comment 1

17 years ago
Created attachment 63234 [details]
full stack strace with locals 

full stack strace with locals
(Reporter)

Comment 2

17 years ago
Created attachment 63235 [details]
console output 

console output at time of crash

Comment 3

17 years ago
wfm using build 2002010103 on Win2k + Flash 5.0r41.

Didn't find dupes besides bug 114235 (using 'PrimaryFrameMapGetKey' as keyword).
Component -> Layout (?)
Severity: normal → critical
Component: Browser-General → Layout
Keywords: crash

Comment 4

17 years ago
Really moving to Layout+reassigning.
Assignee: asa → attinasi
QA Contact: doronr → petersen
David, this is more frame constructions stuff...
see also bug 117118 which has what looks like the same stack.

Comment 7

17 years ago
The content node that continues to be a key in the map after the frame is
destroyed is in this case an object frame, and it seems that the frame was never
removed rather than that it was readded.

Comment 8

17 years ago
*** Bug 117118 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
I've seen this assertion on Window and Mac on many top100 plugin sites since
about a month. Is something leaking?

Comment 10

17 years ago
I see no reason to think there's anything leaking.
Note: It does not crash on WINXP using 2002012203 build.

Object frame related.

Peter, any ideas?  
Assignee: attinasi → peterl

Comment 12

17 years ago
It doesn't crash if you have the relevant plugin (Flash?).  It only crashes if
you don't have the plugin.

Comment 13

17 years ago
Linux--->Serge
Assignee: peterl → serge
(Assignee)

Comment 14

17 years ago
Is there any particular steps to get the crash?
I cannot crash it, with or without flash plugin installed,
I've tried both debug & optimized builds from 01.25.02 cvs trunk,
though I'm getting this assertion on any object tag:
###!!! ASSERTION: frame was not removed from primary frame map before 
destruction or was readded to map after being removed: 
'!PL_DHASH_ENTRY_IS_BUSY(entry) || entry->frame != aFrame', file 
w:\mozilla\layout\html\base\src\nsFrameManager.cpp , line 1003 
(Assignee)

Comment 15

17 years ago
I cannot reproduce the problem
-->mozilla1.0 
Target Milestone: --- → mozilla1.0

Comment 16

17 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2

Comment 17

16 years ago
Marking bugs dealing with re-addition to the primary frame map with [PFM].
Summary: website crashes browser - http://www.mameman.it/ → [PFM]website crashes browser - http://www.mameman.it/

Comment 18

16 years ago
WFM: 1.0rc1 {Build ID: 2002041711} Debian Linux 2.4.17 kernel
no flash plugin installed.

Updated

16 years ago
Target Milestone: mozilla1.2alpha → mozilla1.1alpha

Comment 19

16 years ago
*** Bug 153506 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Severity: critical → normal
(Assignee)

Comment 20

16 years ago
WFM
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.