Browser crashes on startup with User-Agent set

VERIFIED DUPLICATE of bug 83376

Status

()

defect
--
critical
VERIFIED DUPLICATE of bug 83376
18 years ago
18 years ago

People

(Reporter: lmb, Assigned: serhunt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

If the general.useragent.override is set to say "Mozilla/4.0 (compatible; MSIE
5.5; Windows 98; DT)" (because of some stupid incorrectly programmed site, but
we don't want to go into that right now), Mozilla crashes on startup or when
viewing a Java "enabled" website.

I would recommend distinguishing between the externally visible User-Agent and
that communicated to plug-ins.

Exact error message:
INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: No such file or directory



Reproducible: Always
Steps to Reproduce:
1. Add user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 5.5; W
indows 98; DT)"); to user.js
2. Install Java plug in. (I used SUN JDK 1.3.1_02, but IBM also crashed)
3. Start the browser / go to a Java-enabled website

Actual Results:  Immediate browser shutdown with:
INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: No such file or directory

on the console.

Expected Results:  Gracefully informed the user that an error occured with the
Java plugin, respectively omitted a slightly more helpful error message.

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.