Closed Bug 1177351 Opened 4 years ago Closed 4 years ago

[RTL][Email]The ' "t"<testforme1000@outlook.com> ' displays as ' "<t" <testforme1000@outlook.com" '.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:+, b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1177350
tracking-b2g +
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: yue.xia, Unassigned)

References

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(1 file)

Attached image Forward_screenshot2.png
[1.Description]:
[RTL][Flame v2.2&v3.0][N5 v2.2&v3.0][Email]Forward any received mail, on the forwarding compose view, the ' "t"<testforme1000@outlook.com> ' displays as ' "<t" <testforme1000@outlook.com" '.
See attachment: Forward_screenshot2.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic, save an contact with a e-mail address in device.
1. Log in an E-mail account.
2. Launch E-mail and tap a received mail from the contact to enter it.
3. Tap the fifth icon on bottom.
4. Select "Forward" item.
5. Observe the Forwarding compose view.

[3.Expected Result]: 
5. The compose view is displayed as right-aligned and the "GMT+0800(CST)" should displays as ' "t"<testforme1000@outlook.com> '.

[4.Actual Result]: 
5. The compose view is displayed as right-aligned, but the ' "t"<testforme1000@outlook.com> ' displays as ' "<t" <testforme1000@outlook.com" '.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150624162504
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.195750
Firmware Date          Wed Jun 24 19:58:02 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150624080416
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4cdc1a95a672
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.153831
Firmware Date          Wed Jun 24 15:38:44 EDT 2015
Bootloader             L1TC000118D0

Device: N5 2.2 (affected)
Build ID               20150624162504
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150624.195506
Firmware Date          Wed Jun 24 19:55:22 EDT 2015
Bootloader             HHZ12f

Device: N5 3.0 (affected)
Build ID               20150624010204
Gaia Revision          311c4e59936a407e64509f54fecb440d8a78e3c8
Gaia Date              2015-06-20 20:21:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150624.043116
Firmware Date          Wed Jun 24 04:31:35 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
Hi Delphine,
In this issue, there're two problems, the quotes icon("") and braces icon(<>) are all displayed incorrectly. Do you think we could submit two separate bugs to track the quotes icon and braces icon? May I know your suggestion? Thanks! Have a nice day:)
Flags: needinfo?(lebedel.delphine)
Blocks: email-rtl
No longer blocks: settings-rtl
[Blocking Requested - why for this release]:
blocking-b2g: --- → 3.0?
tracking-b2g: --- → +
I *think* you don't need to file separate bugs. If it's needed, I'll let someone else confirm that :)
thanks!
Flags: needinfo?(lebedel.delphine)
Thanks Delphine!
Priority: -- → P1
Blocking for continued RTL support.
blocking-b2g: 2.5? → 2.5+
Duping to bug 1177350 since it's the same root cause and the same fix.
Status: NEW → RESOLVED
blocking-b2g: 2.5+ → ---
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1177350
You need to log in before you can comment on or make changes to this bug.