Closed Bug 1177854 Opened 9 years ago Closed 9 years ago

Enable mozilla-central enabled e10s tests on aurora

Categories

(Release Engineering :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(e10sm7+)

RESOLVED FIXED
Tracking Status
e10s m7+ ---

People

(Reporter: jimm, Assigned: billm)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We need e10s coverage on aurora before we turn e10s on by default.
Assignee: nobody → wmccloskey
Attached patch run-on-auroraSplinter Review
I think this does what we want. Basically, we want to start running the same e10s tests on Aurora that have been running on trunk branches. We don't want this to ride the trains yet. Once we do, we can lock in a specific number.
Attachment #8630243 - Flags: review?(armenzg)
Comment on attachment 8630243 [details] [diff] [review]
run-on-aurora

Review of attachment 8630243 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm.
Land it on default and it will be merged to the production branch which will then be live.
Someone from releng will make a comment in here of when it goes live.
If they don't make a comment you could review http://hg.mozilla.org/build/buildbot-configs/graph and if you see it on the production we can then close this bug (or you could see the jobs running on aurora).
Attachment #8630243 - Flags: review?(armenzg) → review+
We've got a permacrash on Linux32 m-bc:
https://treeherder.mozilla.org/logviewer.html#?job_id=945152&repo=mozilla-aurora
Flags: needinfo?(wmccloskey)
Hmm, this is tricky. I did a try run of Aurora with e10s enabled here:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9a5e664b2f16
You can see that Linux opt bc3 is green.

It's possible that something regressed on Aurora in between then and now. It's also possible that PGO is showing different behavior than opt. It would be nice if I could trigger a non-PGO test run on Aurora, but I can't figure out how to do that with Armen's trigger.py script (don't know the right builder name).

It looks like the content process is crashing at shutdown. The stack seems totally bogus.

I'll do some more try runs and see if they reveal anything.
Flags: needinfo?(wmccloskey)
I've hidden Linux32 m-e10s-bc3 for now on Aurora to get it reopened.
OK, thanks. I did a try push for the same changeset in comment 5 but with PGO enabled.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4f3130921baa
It fails. So the problem is related to PGO. What's weird is that we test this configuration on trunk and it passes. So either something regressed on Aurora since the last merge or else there's something different about Aurora.
Aurora's very different from trunk. DevEdition, ifndef NIGHTLY_BUILD, etc.
Can we close this out? Looks like most of the test are running now.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: