Firefox Hello invitation text

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: frios, Assigned: mternoway)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
>>Project/Request Title:
Firefox Hello invitation text

>>Project Overview:
Requesting review of our copy. 

Firefox Hello is now integrated with Firefox Share. This gives Hello users a variety of channels to invite their friends to join a Hello call (Facebook, Twitter, Gmail, etc). We've prepared copy for each of these invitations and would like to run this by the Creative team. Feedback? Thumbs up? Thank you!

Also requesting one image. The image can be delivered by July 10th.

>> Creative Help Needed:
Copy:    Yes 
Design:  Yes 
Video:   No 
Other:  No

>>Creative Specs:
One image requested to be used for the Facebook invite. PNG, 600x315 (see attachment for guidance)

Copy in Google Doc.

>>CTA and Design:
Document with detail/instruction and our proposed copy here: https://docs.google.com/a/mozilla.com/document/d/19Ftz9EbSoykQy_bO4shRM1m-1BIL3BLIDDwKAhLPz_A/edit?usp=sharing

>>Expected Launch Date:
2015-07-03

>>Mozilla Goal:
Firefox Browser

>>Mozilla Creative Collective:
No

>>Points of Contact:
rtestard@mozilla.com, sfranks@mozilla.com,

Comment 1

3 years ago
Regarding the creative spec, per https://developers.facebook.com/docs/plugins/checklist#opengraphtags Facebook seems to advise use of 1200x630 pixels graphics for better previews.

Comment 2

3 years ago
Assigning the copy review piece over to Matej and adding Matt, since I'm pretty sure he'll work on the Facebook invite graphic.
Assignee: jbalaco → matej
Status: NEW → ASSIGNED
Due Date: 2015-07-03
Component: Design → Copy

Updated

3 years ago
Duplicate of this bug: 1155603

Comment 4

3 years ago
I've gone through and made a few edits. The biggest change is that we can't say "call" or "calls," so I've gone back to referring to them as conversations.

Let me know if you have any questions.
(Reporter)

Comment 5

3 years ago
Adjusted spec for the image. Correct spec is 1200x630 px.

Image should:

1. Convey at a glance this is an invitation for video chat (used in multiple languages so no text in image)
2. Show branding for Firefox Hello
3. Include Firefox logo too, if it fits 

Let me know if you have any questions. Thanks
Flags: needinfo?(mternoway)

Comment 6

3 years ago
Hey Fabio, 

To confirm, the copy is good to go, right? I'm going to change this to a design bug if it is.
(Reporter)

Comment 7

3 years ago
(In reply to Jennifer Balaco from comment #6)
> Hey Fabio, 
> 
> To confirm, the copy is good to go, right? I'm going to change this to a
> design bug if it is.

Confirmed, copy is done. Just need design. Thank you!

Updated

3 years ago
Assignee: matej → mternoway
Due Date: 2015-07-03 → 2015-07-10
Component: Copy → Design
(Assignee)

Comment 8

3 years ago
Hi all, I have a question about what we want to graphically show here to reflect the copy. I'm assuming we want to go in the direction of educating the user on the process, ie showing Hello in action as opposed to the speech bubbles or just faces on screen? If this is the case can we get away with showing just one perspective over the other, example going with what the invitation looks like in an a Facebook setting? Is there a preferred platform that this process should be displayed from? All platform invites seem to be different enough that it might be hard to create a generic looking one in an illustrative style.

- Join me for a video conversation. Click the Firefox Hello link to connect now.
- Join and create video conversations free with Firefox Hello.
- Connect easily over video with anyone, anywhere. No downloads or registration.

Comment 9

3 years ago
(In reply to mternoway from comment #8)
> Hi all, I have a question about what we want to graphically show here to
> reflect the copy. I'm assuming we want to go in the direction of educating
> the user on the process, ie showing Hello in action as opposed to the speech
> bubbles or just faces on screen? If this is the case can we get away with
> showing just one perspective over the other, example going with what the
> invitation looks like in an a Facebook setting? Is there a preferred
> platform that this process should be displayed from? All platform invites
> seem to be different enough that it might be hard to create a generic
> looking one in an illustrative style.
> 
> - Join me for a video conversation. Click the Firefox Hello link to connect
> now.
> - Join and create video conversations free with Firefox Hello.
> - Connect easily over video with anyone, anywhere. No downloads or
> registration.

Overall we want the recipient to click the Hello link - the graphic should support us for this (give trust, understanding and interest to the link clicker so he clicks the Hello link).
Facebook is the highest priority by far (we assume over 90% of our users coming from social networks will be coming from Facebook).
(Assignee)

Comment 10

3 years ago
Created attachment 8635443 [details]
firefox-hello_invitation_facebook_1200x630px.png

Hi all, let me know what you think of this direction for the Hello invite from a recipient point of view. I've used the Facebook setting to illustrate what an invite would look like on a users timeline. Since this needs to accommodate multiple locales I've relied on a simplified stylized look to the setting. Please let me know if this is what you had in mind. 

Thanks,
Matt
Comment on attachment 8635443 [details]
firefox-hello_invitation_facebook_1200x630px.png

An image akin to http://i.sevaan.com/image/142T2W063S2B might help the recipient understand what Firefox Hello is before they click through. Maybe we could test some variations.
(Assignee)

Comment 12

3 years ago
Created attachment 8635811 [details]
firefox-hello_invitation_facebook_1200x630px_v2.png

Thanks Sevaan, I've attached a version 2 option which is more in line with your suggestion. 

MT

Updated

3 years ago
Blocks: 1178304

Updated

3 years ago
Flags: needinfo?(mternoway) → needinfo?(frios)
(Reporter)

Comment 13

3 years ago
Thanks all. I like this graphic, and we've been using it across assets which is great too. I think we are going to need a modified version going forward. 

The concept of the two people using the product is good, specially for the guest who just needs to know they are being invited to the video call. To me this looks very clear, but I asked a few people to tell me what it is about at a glance and I keep getting chat service.

How do we convey video conversation more clearly? I think we are going to have to get two models (people) in mid conversation. In other words, start getting away from animation. We have one of these now, but there's no interaction between the models.

Romain, how are we doing on time with this graphic? Do we have more time to customize further?
Flags: needinfo?(frios) → needinfo?(rtestard)
Mark, this graphic is specifically for the Facebook integration (graphic to be shown in the Facebook invitation.
Per bug 1178304 my understanding is that open graph tags are used on the shared URL's web page - i.e this fully depends on link clicker site release cycles and therefore we probably have a a couple more weeks to complete the visual in readiness for this in 42?
Flags: needinfo?(rtestard) → needinfo?(standard8)

Comment 15

3 years ago
Just wondering where we are with this work. Is there additional design asks? If not, please go ahead and resolve the bug. Thanks!
(Reporter)

Comment 16

3 years ago
Thanks for the ping Jen. There is a request. I'll have them in by Tuesday
Flags: needinfo?(frios)
(Reporter)

Comment 17

3 years ago
(In reply to mternoway from comment #12)
> Created attachment 8635811 [details]
> firefox-hello_invitation_facebook_1200x630px_v2.png
> 
> Thanks Sevaan, I've attached a version 2 option which is more in line with
> your suggestion. 
> 
> MT

Thanks Matt. We are going with this one now.

Note we will be reaching out again soon as the value proposition for Hello will be changing from video calling to sharing the web. We will need to work out a new design to better deliver this message.

Romain, can you use the graphic from comment 12?
Flags: needinfo?(frios) → needinfo?(rtestard)
(In reply to Fabio Rios [:frios] from comment #17)
> (In reply to mternoway from comment #12)
> > Created attachment 8635811 [details]
> > firefox-hello_invitation_facebook_1200x630px_v2.png
> > 
> > Thanks Sevaan, I've attached a version 2 option which is more in line with
> > your suggestion. 
> > 
> > MT
> 
> Thanks Matt. We are going with this one now.
> 
> Note we will be reaching out again soon as the value proposition for Hello
> will be changing from video calling to sharing the web. We will need to work
> out a new design to better deliver this message.
> 
> Romain, can you use the graphic from comment 12?

Yes let's use this one.
We won't depend on release trains to change the graphic so we'll be able to test further variations moving forward wit flexibility.
I have now attached the graphic from comment 12 to follow-up with implementation - Fabio I believe this bug can now be closed since we only need Facebook visual asset and text.
Flags: needinfo?(rtestard)
(Reporter)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.