Gtk3 build fail with /usr/bin/ld: libxul.so: hidden symbol `_ZN26nsMessengerUnixIntegrationC1Ev' isn't defined

RESOLVED FIXED in Thunderbird 42.0

Status

MailNews Core
Build Config
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: fabrixx2, Assigned: Philip Chee)

Tracking

Thunderbird 42.0

Thunderbird Tracking Flags

(thunderbird42 fixed, seamonkey2.39 fixed)

Details

Attachments

(2 attachments)

527.93 KB, text/plain
Details
891 bytes, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
(Reporter)

Description

2 years ago
Created attachment 8626882 [details]
buildlog.txt

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150624153222

Steps to reproduce:

Installed all dependences, 

Creating locals locals 
hg clone http://hg.mozilla.org/l10n-central/it
/l10n/it folder

Downloading source:
hg clone http://hg.mozilla.org/comm-central/
cd comm-central
python client.py checkout

mozconfig:
ac_add_options --enable-application=suite
ac_add_options --enable-default-toolkit=cairo-gtk3
ac_add_options --enable-gstreamer=1.0
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --disable-tests
ac_add_options --enable-official-branding
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-sm-release
mk_add_options MOZ_MAKE_FLAGS="-j4"
export MOZ_DEBUG_SYMBOLS=1
export MOZILLA_OFFICIAL=1
mk_add_options MOZ_CO_LOCALES="it"
ac_add_options --enable-ui-locale=it
ac_add_options --with-l10n-base=/home/fabrizio/Scrivania/l10n





Actual results:

    INPUT("../../modules/zlib/src/uncompr.o")
    INPUT("../../modules/zlib/src/zutil.o")
    INPUT("StaticXULComponentsEnd/StaticXULComponentsEnd.o")

../../mailnews/build/nsMailModule.o: nella funzione "nsMessengerUnixIntegrationConstructor(nsISupports*, nsID const&, void**)":
/home/fabrizio/Scrivania/comm-central/mailnews/build/nsMailModule.cpp:374: riferimento non definito a "nsMessengerUnixIntegration::nsMessengerUnixIntegration()"
/usr/bin/ld: libxul.so: hidden symbol `_ZN26nsMessengerUnixIntegrationC1Ev' isn't defined
/usr/bin/ld: link finale non riuscito: Bad value
collect2: error: ld returned 1 exit status
/home/fabrizio/Scrivania/comm-central/mozilla/config/rules.mk:826: set di istruzioni per l'obiettivo "libxul.so" non riuscito
make[4]: *** [libxul.so] Errore 1
make[4]: uscita dalla directory "/home/fabrizio/Scrivania/comm-central/obj-sm-release/toolkit/library"
/home/fabrizio/Scrivania/comm-central/mozilla/config/recurse.mk:71: set di istruzioni per l'obiettivo "toolkit/library/target" non riuscito
make[3]: *** [toolkit/library/target] Errore 2
make[3]: uscita dalla directory "/home/fabrizio/Scrivania/comm-central/obj-sm-release"
/home/fabrizio/Scrivania/comm-central/mozilla/config/recurse.mk:32: set di istruzioni per l'obiettivo "compile" non riuscito
make[2]: *** [compile] Errore 2
make[2]: uscita dalla directory "/home/fabrizio/Scrivania/comm-central/obj-sm-release"
/home/fabrizio/Scrivania/comm-central/mozilla/config/rules.mk:549: set di istruzioni per l'obiettivo "default" non riuscito
make[1]: *** [default] Errore 2
make[1]: uscita dalla directory "/home/fabrizio/Scrivania/comm-central/obj-sm-release"
client.mk:404: set di istruzioni per l'obiettivo "build" non riuscito
make: *** [build] Errore 2



Expected results:

Impossible to make
(Assignee)

Comment 1

2 years ago
> 07:37	NeilAway	RattyAway: all the references to gtk2 in moz.build need to be updated
> 07:40	NeilAway	actually the only one in mailnews is http://mxr.mozilla.org/comm-central/source/mailnews/base/src/moz.build#62
> 07:41	NeilAway	the tree is wonderfully inconsistent in what it should be replaced by though
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

2 years ago
Created attachment 8633079 [details] [diff] [review]
Untested patch

Untested patch because I don't build on *nix
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8633079 - Flags: review?(neil)
(Assignee)

Updated

2 years ago
Component: Build Config → Build Config
Product: SeaMonkey → MailNews Core
(Assignee)

Updated

2 years ago
Version: Trunk → 39
(Assignee)

Updated

2 years ago
See Also: → bug 1183351

Comment 3

2 years ago
Comment on attachment 8633079 [details] [diff] [review]
Untested patch

I've not tried building on qt, but I guess you're not doing anything GNOME-specific here...
Attachment #8633079 - Flags: review?(neil) → review+
(Assignee)

Comment 4

2 years ago
http://hg.mozilla.org/comm-central/rev/1d834544295f
status-seamonkey2.39: --- → fixed
status-thunderbird42: --- → fixed
Target Milestone: --- → Thunderbird 42.0
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.