Closed Bug 1178122 Opened 5 years ago Closed 4 years ago

ilfattoquotidiano.it serves desktop content to Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1115846

People

(Reporter: marco, Unassigned)

References

()

Details

(Whiteboard: [clientsniff] [country-it] [needscontact])

It works correctly in Firefox for Android.
There's lots of browser/platform detection JS, but all of it is a red herring - the stuff in this file:
http://st.ilfattoquotidiano.it/wp-content/themes/ifq/assets/js/vendor/head.js

actually does a relatively good job:
g=/mobile|android|kindle|silk|midp|phone|(windows .+arm|touch)/.test(p);m.feature("mobile",g,!0),m.feature("desktop",!g,!0)

Inline in the page we have:

	var isTouch = head.touch;
	var isPhone =  head.touch && head.screen.width <= 640;
	var isTablet = head.touch && head.screen.width > 640 && !head.desktop;
	var isDesktop = head.desktop;
	var device = (isDesktop || isTablet) ? 'desktop': 'mobile';

But the real problem is some server-side browser detection that does *not* conclude the same way as the client-side sniffing. The clue is the word "desktop" here:

var scriptToLoad = "http://st.ilfattoquotidiano.it/wp-content/themes/ifq/assets/js/ifqn-desktop-d2a00bf5.js";
Whiteboard: [clientsniff] [country-it] [needscontact]
Still an issue
We contacted twice the website support team to report the issue but at the moment the bug isn't resolved.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1115846
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.