XBL files cannot have a "xbl" file extension

RESOLVED FIXED in mozilla0.9.8

Status

()

P1
enhancement
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: horndog, Assigned: bzbarsky)

Tracking

Trunk
mozilla0.9.8
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Having the binding files clearly marked by file extension would be useful
especially as more sites move to dynamically generated sites powered by
xml/xslt.   *.xbl does not conflict with anything useful at the moment with
regards to mime types.  And for that matter, why would any XML parser *care*
about the extension?  All a parser cares about is that the source is well-formed
and optionally valid.  Why is there any constraint about filename?
(Assignee)

Comment 1

17 years ago
To XBL.  This would not be hard to hack up, in fact... we would just need to 
detect .xbl files as text/xml in the uriloader (fairly simple change).

The icky part is renaming all the files and changing all the links to them....
Status: UNCONFIRMED → NEW
Component: XP Toolkit/Widgets: XUL → XBL
Ever confirmed: true

Comment 2

17 years ago
Your Web server can serve up XBL as text/xml.  Are you concerned about local files?
(Assignee)

Comment 3

17 years ago
I think the concern is over local files and in particular over files in the 
Mozilla source tree.
(Reporter)

Comment 4

17 years ago
I was under the impression that the parser was hard-coding to *.xml for binding
files.

If it is indeed solely a MIME type issue, then I would consider the matter
closed.  It just means that the browser needs a quick tweak to the
extension-to-mimetype list and any web server would be updated (but most access
to XBL or XUL is currently local anyway).

What the Mozilla team uses for a file convention is their own affair.  I have no
preference (and even less say) in the matter.  My concern was only for outside,
unconnected development.  Since I commonly use a great deal of XML and
transformations in my sites, the *.xml extension is growing overused.  It's
becoming like all images are *.image and you can only tell the data types after
pulling the file.  *.xbl would be a valuable visual cue for me (and I assume
others as well) to use in their own projects.  But as before, in response to Mr.
Zbarsky's reply, I feel no great itch to change the way the Mozilla project
handles bindings internally.
(Assignee)

Comment 5

17 years ago
Ah.  Ok.  In that case, this is a trivial change.  Just add "xbl" to the list of 
extensions detected as text/xml in 

http://lxr.mozilla.org/seamonkey/source/uriloader/exthandler/nsExternalHelperApp
Service.cpp#97

hyatt, would that make sense?  As a warning, that list of extension-to-type 
mappings is _not_ overridable by helper app preferences.  Are we _really_ sure 
that nothing uses the xbl extension.

Comment 6

17 years ago
Let's do it.  Supply a patch, and I'll sr it.
(Assignee)

Comment 7

17 years ago
Will do on Monday when I get back from vacation and have a tree once more.  
taking bug.
Priority: -- → P1
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 8

17 years ago
really taking.
Assignee: hyatt → bzbarsky
(Assignee)

Comment 9

17 years ago
Created attachment 64000 [details] [diff] [review]
Patch to detect .xbl as text/xml

Comment 10

17 years ago
Comment on attachment 64000 [details] [diff] [review]
Patch to detect .xbl as text/xml

r=law
Attachment #64000 - Flags: review+

Comment 11

17 years ago
Comment on attachment 64000 [details] [diff] [review]
Patch to detect .xbl as text/xml

sr=hyatt
Attachment #64000 - Flags: superreview+
(Assignee)

Comment 12

17 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.