Closed Bug 1178529 Opened 5 years ago Closed 5 years ago

[Contacts] Contacts list will be dismissed when user attempts to import contacts the second time from an email account that didnt have any on the first attempt

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master verified)

VERIFIED FIXED
FxOS-S4 (07Aug)
blocking-b2g 2.5+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected
b2g-master --- verified

People

(Reporter: AdamA, Assigned: arcturus, Mentored)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark] [good first bug])

Attachments

(4 files)

Attached file logcat
Description:
If the user attempts to import contacts from an email account that does not have any and then they add some and attempt to import from that account again. This happened with a gmail account and a hotmail account. This is only dismissed the second time, after it is dismissed you can import contacts correctly.

Repro Steps:
1) Update a Flame to 20150629010206
2) Enter Contacts
3) Open settings in contacts
4) Choose to import contacts
5) Choose hotmail
6) Sign into a hotmail account with no contacts
7) Dismiss message
8) Add a contact to the hotmail account
9) Attempt to import contacts again
10) Observe screen

Actual:
The screen disappears when there are contacts to import

Expected:
It is expected that users can import contacts when they are available

Environmental Variables:
Device: Flame 2.5 (Full Flash)
Build ID: 20150629010206
Gaia: 8a1e4ae522c121c5cacd39b20a5386ec9055db82
Gecko: eaf4f9b45117
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 10/10
See attached: video clip, logcat
This issue DOES occur on Aries 2.5 and Flame 2.2.

Environmental Variables:
Device: Aries 2.5 (Full Flash)
BuildID: 20150629130633
Gaia: 0b166043ef2a1f235a4d7d4f40a51b625784195a
Gecko: e137fc38c431
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Device: Flame 2.2 (Full Flash)
BuildID: 20150626162505
Gaia: 0179935627012dfde3ca036c9a71035be463b7ad
Gecko: 330f52ef6a2d
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The screen disappears when there are contacts to import
------------------------------------------------------------
This issue DOES NOT occur on Flame 2.1.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150628001204
Gaia: f8b848c82d1ed589f7a1eb5cc099830c867ff1d4
Gecko: d3e432c4546a
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Results:
Users are able to import contacts when the account did not have them previously.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]: Regression which might happen to users who just created a new contact online and wants to sync it to the phone.
blocking-b2g: --- → 2.5?
Mentor: francisco
blocking-b2g: 2.5? → 2.5+
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark] [good first bug]
requesting a window.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
The changes for Bug 1072180 seem to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141029135506
Gaia: 37089e0173b957b8dd950e330db21b4ba7e2b481
Gecko: 111985bd4b21
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141029144815
Gaia: fbb610827cffcebe213385c3343ac2f693f96956
Gecko: b34f41c77be8
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 37089e0173b957b8dd950e330db21b4ba7e2b481
Gecko: b34f41c77be8

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: fbb610827cffcebe213385c3343ac2f693f96956
Gecko: 111985bd4b21

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/37089e0173b957b8dd950e330db21b4ba7e2b481...fbb610827cffcebe213385c3343ac2f693f96956
Blocks: 1072180
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Adrián, can you take a look at this please? This might have been caused by the work done for bug 1072180.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(hola)
Not sure if Adrián is still around. NI'ing Francisco for a potential redirection.
Flags: needinfo?(francisco)
Unfortunately, Adrian is not working in FxOS right now.
Flags: needinfo?(hola)
Attached file Pointer to pr
Flags: needinfo?(francisco)
Assignee: nobody → francisco
Attachment #8638785 - Flags: review?(borja.bugzilla)
Status: NEW → ASSIGNED
Comment on attachment 8638785 [details] [review]
[gaia] arcturus:bug-1178529 > mozilla-b2g:master

Thanks Francisco! :)
Attachment #8638785 - Flags: review?(borja.bugzilla) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/b795c40b149dbfed5348919c4550856bcab7069f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S4 (07Aug)
Keywords: verifyme
This bug has been verified as "pass" on the latest build of Flame KK 2.5 by the STR in comment 0.

Actual results: Users can import contacts when they are available.
See attachment: verified_Flame_v2.5.3gp.
Reproduce rate: 0/15

Device: Flame KK 2.5 (Pass)
Build ID               20150806103226
Gaia Revision          497fe3f938722b0aa49c93f975fad5d9ed3b0a82
Gaia Date              2015-08-06 05:30:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2fad09a0540d
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150806.135403
Firmware Date          Thu Aug  6 13:54:17 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


Note:
I will verify this bug on Aries v2.5 tomorrow.
Keywords: verifyme
This bug has been verified as "pass" on the latest build of Aries KK 2.5 by the STR in comment 0.

Actual results: Users can import contacts when they are available.
See above attachment: verified_Flame_v2.5.3gp.
Reproduce rate: 0/15


Device: Aries KK 2.5(Pass)
Build ID               20150810003528
Gaia Revision          09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gaia Date              2015-08-09 17:11:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0e269a1f1beb
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150810.000017
Firmware Date          Mon Aug 10 00:00:24 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.