Add a 'debug-able things' tab to Firefox

RESOLVED DUPLICATE of bug 1196785

Status

RESOLVED DUPLICATE of bug 1196785
3 years ago
2 months ago

People

(Reporter: canuckistani, Unassigned)

Tracking

41 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

In Whistler Ryan showed us a bunch of plans around the future of WebIDE. In subsequent conversations we identified a specific need in the nearer term for an in-tab UI that provided the developer a list of debug-able things.

The key goal here is to make discovery of debug targets simple:

* I should be able to open a tab from the tools menu that lists debug-able things
* I should be able to see all connected devices ( including valence! )
* I should be able to see any registered workers ( shared, service, etc )
* for a given debug-able item I should be able to launch a toolbox client in a new window
Right, I think this is likely the first piece of folding WebIDE back into the browser to focus on, since it's an independent page separate from the toolbox and we have the short term need of some place to inspect various worker types as well.
Blocks: 1179311
See also the shared / service worker debugging bug. Tge parts of this that target discovering and debugging workers depends on that platform work.
See Also: → bug 1175550
Depends on: 1196785
Jeff, it feels like bug 1196785 is more a duplicate than a dependency. Can we close this one as duplicate? Sorry for not realizing you'd already opened a bug.
Flags: needinfo?(jgriffiths)
(In reply to Jan Keromnes [:janx] from comment #3)
> Jeff, it feels like bug 1196785 is more a duplicate than a dependency. Can
> we close this one as duplicate? Sorry for not realizing you'd already opened
> a bug.

Maybe this one could morph into a meta bug for the whole "project", while bug 1196785 is more about "landing a first version"?  In general I find it nicer to work with meta bugs that depend on various steps of progress, instead of a long-lasting giant bug that spans a large chunk of time and may even land patches across releases (which gets hard to track properly).

I think we'll want some meta bug somewhere, but up to you which one it is.  One of these, a new one not yet filed, etc.
(In reply to Jan Keromnes [:janx] from comment #3)
> Jeff, it feels like bug 1196785 is more a duplicate than a dependency. Can
> we close this one as duplicate? Sorry for not realizing you'd already opened
> a bug.

Do whatever you need to with this bug, but I think I prefer Ryan's idea of a top-level project bug and then a v1 bug that blocks it.
Flags: needinfo?(jgriffiths)
Ok I'll close this as resolved then. Follow-ups can be tracked using bug 1196785's dependencies, and we have plenty other meta-bugs related to specific about:debugging features.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196785
Component: Developer Tools → Developer Tools: about:debugging

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.