Closed Bug 1178606 Opened 5 years ago Closed 5 years ago

[Hackerplace] "Error exporting app" when uploading addon

Categories

(Firefox OS Graveyard :: Gaia::Hackerplace, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox42 fixed)

RESOLVED FIXED
FxOS-S2 (10Jul)
Tracking Status
firefox42 --- fixed

People

(Reporter: mikehenrty, Assigned: fabrice)

References

Details

(Whiteboard: [spark])

Attachments

(1 file)

STR:

1.) create an addon, and install it with WebIDE
2.) Open Hackerplace, and click the upload button
3.) Choose the new addon, and submit the form

Expected Result:
Upload Successful

Actual Result:
Dialog pops up saying ‘error exporting app’.

I've traced the error in Gecko, and it's happening here:
http://hg.mozilla.org/mozilla-central/annotate/13f8dcb5b7a5/dom/apps/ImportExport.jsm#l192
Assignee: nobody → drs
Assignee: drs → fabrice
Any progress here?
Flags: needinfo?(fabrice)
(In reply to Michael Henretty [:mhenretty] from comment #1)
> Any progress here?

The upload panel doesn't display anything for me. Is that a recent regression?
Flags: needinfo?(fabrice)
Flags: needinfo?(mhenretty)
(In reply to Fabrice Desré [:fabrice] from comment #2)
> (In reply to Michael Henretty [:mhenretty] from comment #1)
> > Any progress here?
> 
> The upload panel doesn't display anything for me. Is that a recent
> regression?

This can happen when you don't have any apps installed that can be uploaded to hackerplace. Installing an app or add-on through webIDE should make it show up here. If, however, you installed something through webIDE and you still see nothing, then this is a bug.
Flags: needinfo?(mhenretty)
yep I pushed an add-on from webIDE. What's the criteria you use to decide if something is shareable?
We make sure it's not one of our blacklisted apps (which is basically spark apps), we make sure it's either an addon or a theme, or if not one of those that it was not installed from the marketplace.

https://github.com/fxos/directory/blob/9e21521a7e0fd6d87b2145af965c8a0c94d302e9/app/js/view/upload_view.js#L58
Duplicate of this bug: 1179651
Well, for some reason this add-on doesn't show up:
"sw-enabler.desre.org": {
    "origin": "app://sw-enabler.desre.org",
    "installOrigin": "app://sw-enabler.desre.org",
    "manifestURL": "app://sw-enabler.desre.org/manifest.webapp",
    "appStatus": 3,
    "receipts": [],
    "kind": "packaged",
    "installTime": 1436070244562,
    "installState": "installed",
    "removable": true,
    "id": "sw-enabler.desre.org",
    "basePath": "/data/local/webapps",
    "localId": 1049,
    "sideloaded": true,
    "name": "Incinerate Add-on",
    "csp": "",
    "role": "addon",
    "redirects": null,
    "widgetPages": [],
    "additionalLanguages": {},
    "enabled": true,
    "installerAppId": 0,
    "installerIsBrowser": false,
    "storeId": "",
    "storeVersion": 0,
    "downloading": false,
    "readyToApplyDownload": false
  }

That doesn't make sense to me...
Attached patch bug1178606.patchSplinter Review
Apps sideloaded from webIDE don't have an update manifest, since they don't really come from a remote source. We handle that gracefully in general, ignoring updates for these apps, but we were too strict about having update.webapp in the import/export code.
Attachment #8630861 - Flags: review?(ferjmoreno)
Attachment #8630861 - Flags: review?(ferjmoreno) → review+
https://hg.mozilla.org/mozilla-central/rev/c353ad38b6e8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S2 (10Jul)
Duplicate of this bug: 1182423
You need to log in before you can comment on or make changes to this bug.