Incorrect navigator.userAgent requested via Request Desktop Site

VERIFIED FIXED in Firefox 41

Status

()

defect
VERIFIED FIXED
4 years ago
Last year

People

(Reporter: u421692, Assigned: miketaylr)

Tracking

({regression})

41 Branch
Firefox 42
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 unaffected, firefox40 unaffected, firefox41+ fixed, firefox42+ verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Open http://www.whatsmyua.com/ or http://people.mozilla.org/~atrain/mobile/tests/ua.html

Enable Request desktop site from menu

Actual result:
Incorrect user agent is displayed 
expected UA: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
actual UA: Mozilla/5.0 (Android 4.4.4; Mobile; rv:41.0) Gecko/20100101 Firefox/41.0

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2694ff2ace6a&tochange=c319f262ce3e

Issue regressed from bug 1169772
Oops, my bad.

The regex at https://dxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/browser.js#3206 no longer matches. Will write a patch in a bit.
Assignee: nobody → miket
Mark, would you mind reviewing?

I'm using the following regex which does a non-greedy match from the first digit after "Android " until the first semicolon (same one used in Bug 1175301).

ua.replace(/Android \d.+?; [a-zA-Z]+/, "X11; Linux x86_64")
Comment on attachment 8627706 [details] [diff] [review]
1178761-Fix-DesktopUserAgent-regex-to-account-fo.patch

Thanks for the quick fix, Mike
Attachment #8627706 - Flags: review?(mark.finkle) → review+
Adding r=mfinkle to commit message.

Thanks. I filed Bug 1178798 to add tests for this so I don't break it in the future--shouldn't be very hard but will take me away from some important stuff for too long right now. :/

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a49ba4bb6e64
Attachment #8627706 - Attachment is obsolete: true
See Also: → 1178798
OK, try looks good. Just one known intermittent.
Keywords: checkin-needed
Duplicate of this bug: 1178545
[Tracking Requested - why for this release]: Regression in commonly used feature. Should fix before pushing aurora.
https://hg.mozilla.org/mozilla-central/rev/4dae2b5207a8
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Adding a tracking flag for Firefox41. Kevin, if the patch looks good (has it been verified?), can we request uplift to Aurora?
Flags: needinfo?(kbrosnan)
Flags: qe-verify+
Verified as fixed in build 42.0a1 2015-07-02;
Device: Asus Transformer Pad (Android 4.2.1).
Comment on attachment 8627725 [details] [diff] [review]
1178761-Fix-DesktopUserAgent-regex-to-account-fo.patch

Approval Request Comment
[Feature/regressing bug #]:
"Request Desktop Site" functionality in Fennec (Bug 766406)

[User impact if declined]: 
"Request Desktop Site" will be broken for users until 42.

[Describe test coverage new/current, TreeHerder]:
mfinkle landed tests in Bug 1157319.

[Risks and why]: 
Low risk. This change just fixes a failing regular expression that is only used by the DesktopMode code.

[String/UUID change made/needed]:
None
Comment on attachment 8627725 [details] [diff] [review]
1178761-Fix-DesktopUserAgent-regex-to-account-fo.patch

Approving for uplift to Aurora, has been in m-c for about a week with no known issues. Low risk, tests made.
Attachment #8627725 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.