Closed Bug 1178768 Opened 4 years ago Closed 4 years ago

'Change' buttons in about:telemetry do not open the datachoices preferences on mobile

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 43
Iteration:
43.3 - Sep 21
Tracking Status
firefox39 --- unaffected
firefox40 --- wontfix
firefox41 --- wontfix
firefox42 + wontfix
firefox43 --- verified

People

(Reporter: cos_flaviu, Assigned: gfritzsche)

References

Details

(Keywords: regression, Whiteboard: [unifiedTelemetry] )

Attachments

(1 file, 1 obsolete file)

Environment: 
Device: Motorola Razr (Android 4.4.4);
Build: Nightly 42.0a1 (2015-06-29);

Steps to reproduce:
1. Go to about:telemetry;
2. Tap on 'Change' button.

Expected result:
The telemetry settings can be disabled or enabled from about:telemetry. 

Actual result:
Nothing is happening when tapping on 'change' button. 

Notes:
The following error is thrown in logcat:

JavaScript Error: "TypeError: mainWindow is null" {file: "chrome://global/content/aboutTelemetry.js" line: 24}
Georg, did you test this on mobile?
Flags: needinfo?(gfritzsche)
Ah, no, that slipped through sadly.
Any idea what the equivalent on mobile is to open the datachoices preferences?
Blocks: 1122480
Flags: needinfo?(gfritzsche)
Whiteboard: [uplift2]
Summary: 'Change' buttons form about:telemetry does not work → 'Change' buttons in about:telemetry do not open the datachoices preferences on mobile
[Tracking Requested - why for this release]: regression I do not believe this blocks turning on Aurora updates.
Keywords: regression
Whiteboard: [uplift2] → [unifiedTelemetry] [uplift2]
(In reply to Georg Fritzsche [:gfritzsche] from comment #2)
> Ah, no, that slipped through sadly.
> Any idea what the equivalent on mobile is to open the datachoices
> preferences?

The preferences are native, so you may need to do some JNI hacks for that... I did something similar for the privacy coach add-on:
https://github.com/leibovic/privacy-coach/blob/master/content/welcome.js#L139

We include a version of JNI.jsm in the tree, so you should be able to just import that and use it.

I agree with kbrosnan that I don't think this is a show-stopper.
Adding a tracking flag for Firefox41 and Firefox42 as this a regression and was found during QE Aurora Sign-off testing.
Whiteboard: [unifiedTelemetry] [uplift2] → [rC] [unifiedTelemetry] [uplift3]
Whiteboard: [rC] [unifiedTelemetry] [uplift3] → [rC] [unifiedTelemetry]
Georg,
Flags: needinfo?(gfritzsche)
Georg, is this something that will be fixed for FF41? Is there a patch in progress? Or do you think it is better to track this for FF42 instead?
rnewman also directed me to the about:healthreport code, which uses a supported JS->Java message to show the settings page:

http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/aboutHealthReport.js#120

That's probably better than trying to use JNI :)
This won't make 41, lets track for 42.
(If no-one is assigned to the bug then it isn't actively being worked on.)

Thanks for the pointer Margaret, will try to get here when other work allows :)
Flags: needinfo?(gfritzsche)
Iteration: --- → 43.3 - Sep 21
Points: --- → 1
Whiteboard: [rC] [unifiedTelemetry] → [unifiedTelemetry]
Assignee: nobody → gfritzsche
Status: NEW → ASSIGNED
Attachment #8661693 - Flags: review?(margaret.leibovic)
Comment on attachment 8661693 [details] [diff] [review]
Fix about:telemetry "change" buttons on Fennec

Review of attachment 8661693 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, thanks for the patch!

::: toolkit/content/aboutTelemetry.js
@@ +15,5 @@
>  Cu.import("resource://gre/modules/TelemetryArchive.jsm");
>  Cu.import("resource://gre/modules/TelemetryUtils.jsm");
>  Cu.import("resource://gre/modules/TelemetryLog.jsm");
>  Cu.import("resource://gre/modules/Preferences.jsm");
> +Cu.import("resource://gre/modules/AppConstants.jsm");

This could be a lazy import, since it's not used until the button is clicked.
Attachment #8661693 - Flags: review?(margaret.leibovic) → review+
Attachment #8661693 - Attachment is obsolete: true
Attachment #8661828 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/810363f6cbc3
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Tapping on 'Change' button will open Setting->Mozilla. Is this expected?

Tested on latest Nightly (2015-09-18) on Motorola Razr (Android 4.4.4).
Flags: needinfo?(gfritzsche)
Yes, that is expected.
That page contains the data choices, i.e. what you use to change those settings.
Flags: needinfo?(gfritzsche)
Verified as fixed in build 43.0a1 2015-09-18;
Device: Motorola Razr (Android 4.4.4).
Georg, do you have plans to uplift this patch to 42? Thanks
Flags: needinfo?(gfritzsche)
I don't think this fix is important enough to uplift to Beta, i'd rather leave it riding 43.
Flags: needinfo?(gfritzsche)
OK, thanks. Untracking it then.
You need to log in before you can comment on or make changes to this bug.