Cyrus IMAP: Mozilla ignores IMAP namespace

VERIFIED DUPLICATE of bug 27002

Status

MailNews Core
Networking: IMAP
P5
blocker
VERIFIED DUPLICATE of bug 27002
16 years ago
5 years ago

People

(Reporter: Kristof Petr, Assigned: Karen Huang)

Tracking

({imap-interop})

Trunk
mozilla1.0
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla 0.9.5 works fine.
Versions 0.9.6 and 0.9.7 are broken.

Mozilla ignores NAMESPACE provided by IMAP server
and try to store messages on server with bad path.

Cyrus imapd server 2.0.16 announces Personal NAMESPACE
to "INBOX." and mozilla stores copy of sent mail to
"Sent" mailbox, what is wrong. It should be "INBOX.Sent"
(Reporter)

Comment 1

16 years ago
Server info:

Connected to localhost (127.0.0.1).
Escape character is '^]'.
* OK localhost.localdomain Cyrus IMAP4 v2.0.16 server ready
001 login user password
001 OK User logged in
001 NAMESPACE
* NAMESPACE (("INBOX." ".")) (("user." ".")) (("" "."))
001 OK Completed
001 LOGOUT
* BYE LOGOUT received
001 OK Completed


and Mozilla tries to save Draft message:
001 LIST "" "Drafts"
001 OK Completed (0.000 secs 1 calls)
001 CREATE "Drafts"
001 NO Permission denied

It fails, becouse mozilla operate out of personal namespace.


(Reporter)

Comment 2

16 years ago
Tested with 0.9.5 again. Bad. It seems no one version of mozilla
works correctly with current versions of Cyrus IMAPD.

I did setup test site with cyrus imapd 2.0.16 for imaps
access. Contact me for account.

Comment 3

16 years ago
I confirm this annoying bug.
Tested with different mozilla builds : 2002020118 On W2K, Mozilla 0.98 on Linux
The courier-imap serveur has personal namespace to INBOX., shared namespace to
shared.
The namespaces gets loaded by Mozilla and show up in advanced account server
settings.
But the namespaces are not used by Mozilla-mail as they should
When Mozilla tryes to acces root folders it can't because of the unused
namespace. You have to trick in the settings (copy and folders) specify Sent,
Drafts, Templates as subfolders of INBOX.
The same coveat apply to shared folders as well and Mozilla show unnessary
nesting like
INBOX
  Sent
  Drafts
  Templaes
shared (display gray)
  Mysharearea (display gray)
    Mysharedfolder (display black)

Namespace should be taken as so Mozilla remap root folders according to the
namespace returned by the server as :
INBOX
Sent
Drafts
Templates
Mysharearea (display gray)
  Mysharefolder (display black)


Requested change to this bug report :
New keywords:
interop,  mail3, mozilla0.9.8+, relnote
Platform: all
OS: all
rep_platform: all
(Reporter)

Comment 4

16 years ago
Mozilla works fine IMHO again WU-imapd only. Is there any sane people
what uses this "software"?

I think this is pretty important problem. No one Mozilla developer
check this bugreport. Huang, can you reassign it to different person, please?

Thank Petr
Assignee: mscott → huang
Severity: major → blocker
Priority: -- → P5
Target Milestone: --- → mozilla1.0

Comment 5

16 years ago
Confirmed by Comment #3, changing fields as requested.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: interop, mail3, relnote
OS: Linux → All
Hardware: PC → All

Comment 6

16 years ago
This bug is a duplicate of 27002
http://bugzilla.mozilla.org/show_bug.cgi?id=27002

Same namespace Issue related to INBOX. end shared. prefixed namespaces.

Regards

Léa Gris

Comment 7

16 years ago
Hi, Kristof Petr,

    Give me a account. I'm interested in this bug. I'll try to evaluate it. Thanks.

Henry

Comment 8

16 years ago
Tested on Mozilla 1.0RC1 and still doesn't works. Also tested with courier-IMAP
with NAMESPACE="INBOX." and fails.

Sorry for the spam, but, Kristof please, can you give Henry an account to test
this bug? (We have a guy interested in solving this bug, so give him all the info!!!

Comment 9

16 years ago
Hi, Vicente Salvador, I've got the account from Kristof. I can reproduce this
bug. Sorry that I have to do some other work now and can just put a little
effort on this bug. After May 20, I can focus on this bug.
(Assignee)

Comment 10

16 years ago

*** This bug has been marked as a duplicate of 27002 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 11

16 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
QA Contact: huang → meehansqa
(Assignee)

Updated

16 years ago
Summary: Mozilla ignores IMAP namespace → Cyrus IMAP: Mozilla ignores IMAP namespace

Comment 12

16 years ago
I give a patch in bug 27002.
Product: MailNews → Core
Product: Core → MailNews Core
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.