Closed Bug 1179189 Opened 4 years ago Closed 4 years ago

Fix the Telemetry environment e10s value

Categories

(Toolkit :: Telemetry, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla42
Iteration:
42.3 - Aug 10
Tracking Status
e10s - ---
firefox40 --- wontfix
firefox41 --- fixed
firefox42 --- fixed

People

(Reporter: rvitillo, Assigned: gfritzsche)

References

Details

(Whiteboard: [unifiedTelemetry] [uplift4])

Attachments

(1 file)

According to our data, about 20% of Nightly submissions have e10sEnabled set to true in the environment section [1] but more than 90% of submissons have the E10S_AUTOSTART histogram set to true [2].

Do the numbers make sense? Which flag should be used for anlyses to discern between e10s and non-e10s sessions?

[1] https://dxr.mozilla.org/mozilla-central/source/toolkit/components/telemetry/TelemetryEnvironment.jsm#975
[2] https://dxr.mozilla.org/mozilla-central/source/toolkit/xre/nsAppRunner.cpp#4660
Flags: needinfo?(mconley)
Looks like the e10sEnabled measurement checks the browser.tabs.remote.autostart pref, and E10S_AUTOSTART measures what is effectively the value of Services.appinfo.browserTabsRemoteAutostart.

browser.tabs.remote.autostart is a pref that is set to true when the user opts into e10s, either via the popup notification that we showed Nightly before it was enabled by default, or by toggling it manually in about:preferences.

Services.appinfo.browserTabsRemoteAutostart is a measurement of how many users actually have e10s enabled (not only have they got the prefs set to enable it, but their hardware configuration actually allows them to run it as well).

So the number you should use to discern between e10s and non-e10s sessions is E10S_AUTOSTART. I'm not sure if e10sEnabled has much utility, tbh.

felipe - do you think there's any value in measuring how many users have browser.tabs.remote.autostart set?
Flags: needinfo?(mconley) → needinfo?(felipc)
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #1)
> felipe - do you think there's any value in measuring how many users have
> browser.tabs.remote.autostart set?

No, I don't think so. I had already reported this in bug 1153326, but Benjamin thought in comment 2 there that it was valuable. I believe it makes less sense now that we've had e10s opt-out for a long time, because the only users who have browser.tabs.remote.autostart set to true are:

- users who opted-in to e10s a long ago while it was still opt-in and not opt-out (on nightly)
- users who disabled e10s for some problem and then later decided to re-enable it manually
Flags: needinfo?(felipc)
I suppose it's still valuable on the builds where e10s is still opt-in, like Dev Edition?

Perhaps we should rename the e10sEnabled measurement to e10sOptIn.

Is this enough information, rvitillo?
Flags: needinfo?(rvitillo)
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #3)
> I suppose it's still valuable on the builds where e10s is still opt-in, like
> Dev Edition?
> 
> Perhaps we should rename the e10sEnabled measurement to e10sOptIn.
That makes sense. George, can we rename that field?

> Is this enough information, rvitillo?
It is, thanks.
Flags: needinfo?(rvitillo) → needinfo?(gfritzsche)
If it is currently not used for analysis, we can just rename it and update the docs.

Can we reliably grab the same value as E10S_AUTOSTART from TelemetryEnvironment.jsm somehow?
I expect that will be really valuable to have in the environment once e10s-on-by-default rides the trains.
Flags: needinfo?(gfritzsche)
Blocks: 1122482
It's used only in the v4 aggregator afaik, I can easily change that. I agree that we should have the value of E10S_AUTOSTART somewhere in the environment as it's important for analyses.
Not tracking - sounds like rvitillo knows what to do her. Feel free to needinfo me if you have more questions.
tracking-e10s: --- → -
(In reply to Georg Fritzsche [:gfritzsche] from comment #5)
> Can we reliably grab the same value as E10S_AUTOSTART from
> TelemetryEnvironment.jsm somehow?

I don't see right now where we can pull this value from.
I'd rather not depend on the E10S_AUTOSTART histogram - if possible i'd like to remove it in favor of the environment addition.
Flags: needinfo?(mconley)
(In reply to Georg Fritzsche [:gfritzsche] from comment #8)
> (In reply to Georg Fritzsche [:gfritzsche] from comment #5)
> > Can we reliably grab the same value as E10S_AUTOSTART from
> > TelemetryEnvironment.jsm somehow?
> 
> I don't see right now where we can pull this value from.
> I'd rather not depend on the E10S_AUTOSTART histogram - if possible i'd like
> to remove it in favor of the environment addition.

You can use Services.appinfo.browserTabsRemoteAutostart for that, I believe.
Flags: needinfo?(mconley)
Attachment #8642308 - Flags: review?(mconley)
Assignee: nobody → gfritzsche
Status: NEW → ASSIGNED
Summary: Semantic of e10sEnabled → Fix the Telemetry environment e10s value
Iteration: --- → 42.3 - Aug 10
Whiteboard: [unifiedTelemetry] [uplift4]
Comment on attachment 8642308 [details] [diff] [review]
Semantic of e10sEnabled

Review of attachment 8642308 [details] [diff] [review]:
-----------------------------------------------------------------

Not sure what this is going to do to the e10sEnabled graph on the dashboard. You might want to heads-up anybody watching that thing that we're about to change the meaning of this value.
Attachment #8642308 - Flags: review?(mconley) → review+
I will add this to the errata.
Note that this is newly added data for unified Telemetry, so i'm not really concerned about breaking fixes here.
https://hg.mozilla.org/mozilla-central/rev/9900bb712ae7
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Comment on attachment 8642308 [details] [diff] [review]
Semantic of e10sEnabled

Approval Request Comment
[Feature/regressing bug #]:
Telemetry Unification
[User impact if declined]:
This is a minor fix to how we detect whether e10s is enabled.
It is part of a mostly fixup & diagnostic uplift batch for 41: http://bit.ly/1LYhA16
[Describe test coverage new/current, TreeHerder]:
We have automated test-coverage, it baked on Nightly.
[Risks and why]:
Low-risk, fine on Nightly.
[String/UUID change made/needed]:
None.
Attachment #8642308 - Flags: approval-mozilla-aurora?
Comment on attachment 8642308 [details] [diff] [review]
Semantic of e10sEnabled

Simple change, let's uplift to Aurora.
Attachment #8642308 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1153326
You need to log in before you can comment on or make changes to this bug.