[Tablet] Fix Android L "share" list item in long press context menu

VERIFIED FIXED in Firefox 68

Status

()

defect
P3
normal
VERIFIED FIXED
4 years ago
23 days ago

People

(Reporter: ioana.chiorean, Assigned: adam.orban)

Tracking

(Blocks 1 bug, {good-first-bug})

Trunk
Firefox 69
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+, firefox54 wontfix, firefox55 wontfix, firefox56 wontfix, firefox64 wontfix, firefox65 wontfix, firefox66 wontfix, firefox67 wontfix, firefox68 verified, firefox69 fixed)

Details

(Whiteboard: [bcs:p2])

Attachments

(5 attachments, 1 obsolete attachment)

Reporter

Description

4 years ago
Posted image Screenshot
Bug 1132747 fixed only the mobile side.

Steps:
- Open context menu on several links ( preferably without having any quick search options set) 

Expected results:
-the options should be aligned  

Actual results:
- Share option sis more on the left side
Flags: needinfo?(michael.l.comella)
Reporter

Comment 1

4 years ago
ni on Martyn as I hears mcomella is in PTO
Flags: needinfo?(mhaigh)
Yuck that is one sloppy looking menu.
tracking-fennec: --- → ?
Ioana, what device are you using? I can't repro on my N9 running Lollipop.
Flags: needinfo?(michael.l.comella) → needinfo?(ioana.chiorean)
Assignee: nobody → michael.l.comella
Reporter

Comment 5

4 years ago
Nexus 7 - all branches Nightly 42.0a1 , Aurora 41.0a2, Beta/RC 39
Flags: needinfo?(ioana.chiorean)
tracking-fennec: ? → +
I'm not going to get to this anytime soon.
Assignee: michael.l.comella → nobody
Reporter

Updated

2 years ago
tracking-fennec: + → ?

Updated

2 years ago
tracking-fennec: ? → +
Keywords: good-first-bug
Priority: -- → P3

Comment 7

2 years ago
[triage@0719] good 1st bug. + w/ P3

Comment 8

Last year
Posted image Share Link 2.png
This also happens when accessing the Share Link context menu and the Share Video menu. Some icons have a different size in the context menu. Added new attachment with a snapshot of it.

Updated

Last year
Version: unspecified → Trunk

Comment 9

9 months ago
I can confirm the different icon sizes on Android Oreo 8.1 when sharinga link.
Maybe Firefox should use the system default share chooser dialog for sharing links like most other apps do?
Duplicate of this bug: 1510891

Comment 11

2 months ago

It seems to be fixed in Firefox 66.
The share menu looks good now on Oreo here. All icons are displayed in the same size.

Thanks for the fix!

Assignee

Updated

2 months ago
Assignee: nobody → adam.orban
Status: NEW → ASSIGNED
Assignee

Updated

Last month
Keywords: checkin-needed

Adam, could you take a look over this? Lando complains about one of these:

Lando says "This diff does not have the proper author information uploaded to Phabricator", but I see an author on Phabricator. What's wrong?

There are a few reasons this could happen:

The revision was created via the Phabricator Web UI or via an unsupported client.
    Use arcanist or moz-phab to submit the patch instead; see the Mozilla Phabricator User Guide for help.

The revision was created via arcanist or moz-phab, but the error still appears.
    This can happen if you have not set an author email in your .hgrc file (or git config). Set your author email in your .hgrc to your username, Firstname Lastname <yourldapemail@mozilla.com>. Update your commit so it contains the new author data. Re-run moz-phab submit or arc diff so that the new commit+data is uploaded to Phabricator.
Flags: needinfo?(adam.orban)
Keywords: checkin-needed
Attachment #9063976 - Attachment is obsolete: true
Assignee

Updated

Last month
Flags: needinfo?(adam.orban)
Keywords: checkin-needed

Comment 15

Last month

Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4a49d2484923
[Tablet] Fix Android L "share" list item in long press context menu; r=petru

Keywords: checkin-needed

Comment 16

Last month
bugherder
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Assignee

Updated

Last month
Flags: qe-verify+

Re-opened in the latest Beta version 68.0b3.
Note that I was able to reproduce this issue on the context menu.
But as discussed on the above comments regarding Share Link context menu like Comment 8 the issue cannot be reproduced in that menu.
I was able to reproduce this issue using: Lenovo TB3 (Android 6.0).
And I couldn't reproduce the issue using: Xiaomi Mi Pad 2 (Android 5.1).
For more details please see the picture.

Thanks,
Andrei

Status: RESOLVED → REOPENED
Flags: qe-verify+
Resolution: FIXED → ---
Flags: qe-verify+
Flags: needinfo?(adam.orban)
Assignee

Updated

Last month
Flags: needinfo?(adam.orban)
Keywords: checkin-needed

Comment 21

Last month

Pushed by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/808ad8234b40
[Tablet] Fix Android L "share" list item in long press context menu; r=petru

Keywords: checkin-needed

Comment 22

29 days ago
bugherder
Status: REOPENED → RESOLVED
Closed: Last month29 days ago
Resolution: --- → FIXED
Target Milestone: Firefox 68 → Firefox 69

Adam, can you please request uplift of your patches to Fennec 68 Beta? We'll be supporting Fennec 68 in ESR until mid-2020 so it would be nice to have your fix.

Whiteboard: [bcs:p2]
Assignee

Comment 24

28 days ago

Comment on attachment 9065311 [details]
Bug 1179266 - [Tablet] Fix Android L "share" list item in long press context menu; r?petru

Beta/Release Uplift Approval Request

  • User impact if declined: Small visual issue in that the share options are not properly aligned
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open context menu on several links ( preferably without having any quick search options set)
    check the visual alignment
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small targeted code change
  • String changes made/needed:
Attachment #9065311 - Flags: approval-mozilla-beta?
Assignee

Updated

28 days ago
Attachment #9067681 - Flags: approval-mozilla-beta?
QA Whiteboard: [qa-triaged]

Comment on attachment 9065311 [details]
Bug 1179266 - [Tablet] Fix Android L "share" list item in long press context menu; r?petru

fennec fix for 68.0b7

Attachment #9065311 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9067681 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9065311 [details]
Bug 1179266 - [Tablet] Fix Android L "share" list item in long press context menu; r?petru

actually this first patch is already on 68.

Attachment #9065311 - Flags: approval-mozilla-beta+

Verified as fixed in the latest nightly build 68.0a1 with Lenovo TB3 (Android 6.0).
Tomorrow I will verify this issue on the beta and mark the bug as verified if everything will be fine.

Flags: needinfo?(andrei.bodea)

Verified as fixed in the latest beta build 68.0b7 with Lenovo TB3 (Android 6.0).

Flags: needinfo?(andrei.bodea)
Flags: qe-verify+

Comment 30

23 days ago

Verified on Firefox Nightly 68.0a1(2019-06-03) with device Lenovo TB3 (Android 6.0) with status fixed.
Ticket will be marked as Verified - Fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.