Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 117950 - Input checkbox's readonly attribute ignored
: Input checkbox's readonly attribute ignored
Status: RESOLVED DUPLICATE of bug 88512
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: rods (gone)
: Madhur Bhatia
: Jet Villegas (:jet)
Depends on:
  Show dependency treegraph
Reported: 2002-01-03 09:10 PST by Rick DeBay
Modified: 2002-01-03 09:36 PST (History)
0 users
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Rick DeBay 2002-01-03 09:10:51 PST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

The readonly attribute of checkboxes are ignored.
I haven't tested other input controls.

Reproducible: Always
Steps to Reproduce:
1.Run testcase
2.Modify readonly checkbox
4.Examine URL

Actual Results:  Readonly checkbox was modified and submitted.

Expected Results:  Not allowed readonly checkbox to be modified.
Comment 1 Christopher Aillon (sabbatical, not receiving bugmail) 2002-01-03 09:36:47 PST

*** This bug has been marked as a duplicate of 88512 ***

Note You need to log in before you can comment on or make changes to this bug.