Closed Bug 1179754 Opened 4 years ago Closed 4 years ago

[Windows] Unable to access window controls after entering full screen

Categories

(Firefox :: General, defect, P4)

39 Branch
All
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox39 --- affected
firefox40 --- affected
firefox41 --- affected
firefox42 --- affected

People

(Reporter: avaida, Unassigned)

References

(Blocks 2 open bugs)

Details

Reproducible on:
* Firefox 39.0 RC (build6: 20150630154324) - intermittently
* Aurora 40.0a2 (2015-06-29)
* Nightly 42.0a1 (2015-07-01)

Affected platforms:
* Windows 10 Pro (x64) Insider Preview Build 10158
* Windows 8.1 Pro (x64) - intermittently
* Windows 7 (x64) - intermittently

Steps to reproduce:
1. Launch Firefox.
2. Press [F11] to enter full screen.
3. Position the mouse cursor at the top or top corners of the screen to make the window controls / title bar (e.g. minimize, maximize, etc.) visible.

Expected result:
The title bar along with the window controls are visible if the cursor is positioned at the top of the screen.

Actual result:
* On Windows 10, the user is unable to bring up the title bar once he enters full screen. The only way to exit full screen is by pressing [F11] once again.
* On Windows 8.1 / 7, the same behavior occurs but intermittently (read rarely). Most of the times, the title bar/window controls are made visible.

Additional notes:
* This doesn't seem to be a recent regression but it occurs more often on Windows 10 than other.
Blocks: windows-10
I tested on Windows 10 Pro Insider Preview Build 10162 (x64) with Nightly 42.0a1 (2015-07-06), but I cannot reproduce this issue with the STR in comment 0. Not sure what's wrong there.
(In reply to Xidorn Quan [:xidorn] (UTC+12) from comment #1)
> I tested on Windows 10 Pro Insider Preview Build 10162 (x64) with Nightly
> 42.0a1 (2015-07-06), but I cannot reproduce this issue with the STR in
> comment 0. Not sure what's wrong there.

I'm also having trouble reproducing this on Build 10162. Tried with a Microsoft Surface Pro 2 and also with my regular desktop PC, with no luck.
I can't reproduce this either. Calling it a P4 based on it being pre-existing and hard to reproduce, but if someone can figure out how to trigger this more reliably it would be helpful (and probably increase priority).
Priority: -- → P4
Resolving WFM based on the comments.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.