Closed Bug 1179764 Opened 5 years ago Closed 5 years ago

Facebook and the Spinning Wheel of Doom! (inline cursor: pointer never removed from documentElement)

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mozilla, Unassigned)

Details

(Whiteboard: [country-all][sitewait])

Attachments

(2 files)

Attached image FullSizeRender.jpg
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Open up Facebook in the latest Firefox. Clicked on a post that reloads in the same tab.


Actual results:

Once the tab refreshed with the new content I constantly get the Mac blue spinning wheel. It happens if I hover over ANYTHING on the Facebook page (not just content, but outside of the page area). When I first visit, it is fine, but once I click on something that is it. Not sure if it's Firefox, or FB or FF and FB?


Expected results:

Erm, no spinning wheel please! :-)
I submitted a support request, and so far 44 people are having this issue on my topic, which can be found here: https://support.mozilla.org/en-US/questions/1069928
This has been reported in the FB Community Forums:

https://www.facebook.com/help/community/question/?id=1600836403501526

And in a FB group I admin.  FF and clones only, Chrome/clones are not affected.
this is producing quite a lot of feedback on sumo as well:
https://support.mozilla.org/en-US/questions/firefox?tagged=bug1179764&show=all
Status: UNCONFIRMED → NEW
Ever confirmed: true
We've already escalated this with Facebook contacts, hopefully a fix will be deployed by Facebook soon.
Hi Justin, do you know if FB knows what the bug is? 

I did some poking around and it seems to be a bug in their `stopLookingBusy` method: https://github.com/webcompat/web-bugs/issues/1331#issuecomment-118227563. (Bug is present in all browsers, but only non-WebKit ones get visible side effects). 

Given that, I'm going to move to Tech Evangelism.
Component: Untriaged → Desktop
Product: Firefox → Tech Evangelism
Version: 38 Branch → Trunk
Summary: Facebook and the Spinning Wheel of Doom! → Facebook and the Spinning Wheel of Doom! (inline cursor: pointer never removed from documentElement)
Whiteboard: [country-all][sitewait]
Attached image CPU Usage
I'm not sure if they are linked, but if you look at this screen grab you will see Firefox can be running at nearly 70% of my CPU! Is this normal? Is it related to this bug?
It spikes when I click a link in Facebook and navigate to another page. A Google search creates around 30% CPU usage.
I agree, my CPU usage was through the roof, and the task manager showed Firefox was using over 350 MB.
This is also happening to me on Fedora 22 with Firefox 38.0.5.  I tried downgrading to 38.0.1 but the problem remains.  Now that I dig a little deeper, this version of firefox has been installed since Jun 07, 2015 so this is almost certainly a facebook issue.

FWIW, the symptoms for me include a near complete lockup of firefox to the point where the only way I can close it is to kill it.  Periodically reloading the facebook page whenever the spinning icon appears seems to help but it a very temporary fix.
CPU usage is probably unrelated to this specific bug--feel free to file new bugs. The spinning icon is just set by CSS and has nothing to do with any real work by the CPU/browser.

See Comment #5 for a link to the problem.

Harald, can you pass this along to your FB contacts as well?
I guess in my case I see the Pointer w/ Hourglass cursor in Windows 7 Pro 64bit with Firefox 39.0 release.
Thanks Mike. I have very few AddOns loaded and my plugins are up to date, but will try loading them one by one to see what causes the CPU issue. As I said, I wasn't sure if it was related, it was just the highest CPU usage I got was during Facebook sessions. Cheers, G
I can no longer reproduce the issue. Anyone?
You're right Kohei! I see the spinning wheel when I click something but now it actually stops and goes away. I guess FB have addressed the issue. Thanks for sorting this out everyone involved. Will let you know when it it happens again! ;-) G
Yep, looks like it's fixed now. Thanks Facebook!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.