Closed Bug 1179871 Opened 4 years ago Closed 2 years ago

Busy Web Workers should not make the chrome UI unresponsive

Categories

(Core :: DOM: Workers, defect, P5)

38 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1300658

People

(Reporter: nick, Unassigned)

Details

From the Worker Spec [0], there's a demo page [1] that makes FF completely unresponsive [1].  The worker is running [2]:

var n = 1;
search: while (true) {
  n += 1;
  for (var i = 2; i <= Math.sqrt(n); i += 1)
    if (n % i == 0)
     continue search;
  // found a prime!
  postMessage(n);
}

[0] https://w3c.github.io/workers/
[1] https://www.whatwg.org/demos/workers/primes/page.html
[2] https://whatwg.org/demos/workers/primes/worker.js
Priority: -- → P5
This was fixed in bug 1300658.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1300658
You need to log in before you can comment on or make changes to this bug.