Closed Bug 1180260 Opened 4 years ago Closed 4 years ago

2px border on url bar and search field looks uneven

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: phlsa, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Attached image uneven-border.png
It looks like the 2px border used in the hover/active states of the url bar and search bar has some pixel-fitting issues.
It is slightly narrower on the top and the right. This happens with 200% and 250% text scaling (didn't test other variants so far)
Text scaling? Are you sure?

I'm not seeing this at 200% full scaling (i.e. high DPI).
I mean the thing that can be set in the system settings that scales the whole UI (it was called text scaling once, but doesn't seem to have a name anymore now).

I'm seeing this on both my Hidpi screens. It varies a bit between scale factors (different edges are thicker), but it happened with every scale facter I've tried. That includes 100% for some reason...

It seems to be fine in my VM though, so perhaps it has something to do with the screen?
Attached patch workaroundSplinter Review
Workaround in case bug 1181554 doesn't make it into Firefox 40.
Priority: -- → P1
Fixed by bug 1181554, looks normal to me now.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
I can confirm that this issue is indeed fixed using a Microsoft Surface Pro 2 device running Windows 10 64-bit.
Tested on latest Nightly, build ID: 20150721030212.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.