Add headers for classes in TOC of Puppeteer docs

RESOLVED FIXED in Firefox 42

Status

Testing
Firefox UI Tests
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: utvar, Assigned: utvar)

Tracking

unspecified
mozilla42
Points:
---

Firefox Tracking Flags

(firefox42 fixed, firefox-esr38 fixed)

Details

Attachments

(1 attachment)

52 bytes, text/x-github-pull-request
chmanchester
: review+
chmanchester
: feedback+
Details | Review | Splinter Review
(Assignee)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

I navigated to Puppeteer Read the Docs (via GitHub link or search engine results) and looked at drop-down menus for the libraries in the main table of contents on the left. 


Actual results:

Some libraries had all of their classes listed in drop-down menu, but others were missing one or all of the classes they contain. 


Expected results:

I expected all of the libraries to have all their classes listed in the table of contents.
(Assignee)

Comment 1

3 years ago
I have started addressing this issue here: https://github.com/mozilla/firefox-ui-tests/pull/210
Assignee: nobody → utvar
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

3 years ago
Created attachment 8632478 [details] [review]
GitHub pull request

Comments on GitHub.
Attachment #8632478 - Flags: feedback?(cmanchester)
Comment on attachment 8632478 [details] [review]
GitHub pull request

Thanks for the PR, this looks like a good change to me! Is there anything you'd like feedback on in particular before I merge this in?
Attachment #8632478 - Flags: feedback?(cmanchester) → feedback+
(Assignee)

Comment 4

3 years ago
(In reply to Chris Manchester [:chmanchester] from comment #3)

I wanted to be sure you approved of the removal of the "API Reference" headers. I believe it makes the TOC clearer to have all the classes show up directly under the name of the library, but if you prefer, I could add another layer to the TOC and index, which would nest class names inside the "API Reference" header.
(Assignee)

Comment 5

3 years ago
Comment on attachment 8632478 [details] [review]
GitHub pull request

Please see Bug 1180429, Comment4.
Attachment #8632478 - Flags: feedback?(cmanchester)
Comment on attachment 8632478 [details] [review]
GitHub pull request

Looks good! I'll merge this in a moment.
Attachment #8632478 - Flags: feedback?(cmanchester) → review+
(Assignee)

Updated

3 years ago
Summary: Missing headers for classes in TOC of Firefox Puppeteer docs → Add headers for classes in TOC of Puppeteer docs
Merged to master in https://github.com/mozilla/firefox-ui-tests/commit/42d9132e31869d1b1baaf752b881233c9bcd3972
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
status-firefox42: --- → fixed
We needed this patch for esr38 to get some other important patches backported. So I cherry-picked this commit:

https://github.com/mozilla/firefox-ui-tests/commit/b24a98110e31dbc48b5737678c69d1e73baa6542 (esr38)
status-firefox-esr38: --- → fixed
Product: Mozilla QA → Testing
You need to log in before you can comment on or make changes to this bug.