Disable BackgroundHangMonitor on gonk

RESOLVED FIXED in Firefox 42

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: fabrice, Assigned: fabrice)

Tracking

Trunk
mozilla42
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox40 wontfix, firefox41 wontfix, firefox42 fixed, b2g-v2.2 fixed, b2g-v2.2r fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 years ago
This is causing too many wakeups and hurts battery life, and we have people doogfooding on non-released channels so we need to force it off on gonk.
Assignee

Comment 1

4 years ago
Attachment #8629717 - Flags: review?(vdjeric)
Comment on attachment 8629717 [details] [diff] [review]
background-hang-monitor.patch

Review of attachment 8629717 [details] [diff] [review]:
-----------------------------------------------------------------

::: xpcom/threads/moz.build
@@ +59,5 @@
>      '/tools/profiler',
>  ]
>  
>  # BHR disabled for Release builds because of bug 965392.
>  # BHR disabled for debug builds because of bug 979069.

add another comment linking to this bug
Attachment #8629717 - Flags: review?(vdjeric) → review+
Just my 2p: it might have been worth adding a comment as to why we're disabling the monitor on b2g.
https://hg.mozilla.org/mozilla-central/rev/ce4ca807b6a7
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
I know it's late but nominating for v2.2+ nevertheless because the fix is trivial and the problem quite severe when it manifests itself.
blocking-b2g: --- → 2.2?
Thanks Fabrice,
Do you mind raise the uplift request for 2.2? Thanks!
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(fabrice)
Also NI 2.2r EPM Wesley as this also required for 2.2r.
Flags: needinfo?(whuang)
Yes. Would like to pick 2.2+ blockers to 2.2r as well.
Flags: needinfo?(whuang)
Assignee

Comment 10

4 years ago
Comment on attachment 8629717 [details] [diff] [review]
background-hang-monitor.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: battery life suffers.
Testing completed: 
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Flags: needinfo?(fabrice)
Attachment #8629717 - Flags: approval‑mozilla‑b2g37_v2_2r?
Attachment #8629717 - Flags: approval-mozilla-b2g37?
Comment on attachment 8629717 [details] [diff] [review]
background-hang-monitor.patch

We're doing v2.2->v2.2r merges still.
Attachment #8629717 - Flags: approval‑mozilla‑b2g37_v2_2r?

Updated

4 years ago
Attachment #8629717 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.