Closed Bug 1180645 Opened 5 years ago Closed 5 years ago

Fancy Pants flash app does not work with the low integrity NPAPI plug-in sandbox enabled

Categories

(Core :: Plug-ins, defect)

41 Branch
All
Windows
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1180684
Tracking Status
firefox39 --- unaffected
firefox40 --- unaffected
firefox41 --- affected
firefox42 --- affected

People

(Reporter: avaida, Unassigned)

References

Details

Reproducible on:
* Nightly 42.0a1 (2015-07-05)
* Aurora 41.0a2 (2015-07-05)

Affected platforms:
* Windows 10 Pro x64 (Insider Preview Build 10158)
* Windows 8.1 Pro x64
* Windows 7 x64

Steps to reproduce:
1. Launch Firefox.
2. Enable the low integrity NPAPI plug-in sandbox for Flash by setting "dom.ipc.plugins.sandbox-level.flash" to "2". Restart the browser to make sure this setting is applied.
3. Visit http://www.addictinggames.com/action-games/fancypantsadventure.jsp and try to use the game.

Expected result:
The game is responsive and works as expected, without causing any hangs or crashes.

Actual result:
The game's controls are not working - keyboard input is ignored.

Additional notes:
* This issue is reproducible on both 64-bit and 32-bit Nightly 42, with and without having that pref set to 2.
* I've checked this game on Google Chrome 43.0.2357.130 m and it works fine.
* This issue is NOT reproducible on Release 39.0 32-bit (20150630154324) and Beta 40.0b1 (20150702173756, where the pref is not configured, although hangs are occurring intermittently.
Andrei, please set NI?bobowen on any bugs related to the NPAPI sandbox.
Flags: needinfo?(bobowen.code)
(In reply to Andrei Vaida, QA [:avaida] from comment #0)

> Additional notes:
> * This issue is reproducible on both 64-bit and 32-bit Nightly 42, with and
> without having that pref set to 2.

Andrei, thanks for finding this.

This game works for me with the pref set to 0.
Did you restart after setting the pref back to 0?

(If it does work for you with pref of 0, I'll probably de-duplicate to bug 1180684 as that seems like the more generic case.)
Flags: needinfo?(bobowen.code) → needinfo?(andrei.vaida)
(In reply to Bob Owen (:bobowen) from comment #2)
> Andrei, thanks for finding this.
> 
> This game works for me with the pref set to 0.
> Did you restart after setting the pref back to 0?
> 
> (If it does work for you with pref of 0, I'll probably de-duplicate to bug
> 1180684 as that seems like the more generic case.)

I think that was the case, I've just updated to Nightly 42.0a1 (2015-07-07) and the game works with the pref set to 0.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(andrei.vaida)
Resolution: --- → DUPLICATE
Duplicate of bug: 1180684
You need to log in before you can comment on or make changes to this bug.