Closed Bug 1180648 Opened 4 years ago Closed 4 years ago

(foxfood) you are not allowed to reach the full gmail.com

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 668275

People

(Reporter: armenzg, Assigned: karlcow)

References

()

Details

(Keywords: dogfood, Whiteboard: [bzlite] [country-all])

Attachments

(1 file)

User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

When I visit gmail.com, you get asked if you would like to use the full on gmail site or the HTML version of it.
Even if you choose the "full" site you get redirected again to the same page asking you which version you want.
Mike, Taylor, any thoughts on this? Looks like a tech evangelism issue to me.
Component: Gaia::Feedback → Mobile
Flags: needinfo?(miket)
Flags: needinfo?(kdubost)
Product: Firefox OS → Tech Evangelism
Fixing the bug report.
Flags: needinfo?(kdubost)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [bzlite] → [bzlite] [country-all]
Assignee: nobody → kdubost
Armen, 
it seems we do not have the same UI ^_^
Could you provide more details on how to reproduce the bug you are experiencing. 

Note also 
* Bug 1036987 (XHTML for search issues)
* Bug 668275  (lowfi version)

I'm trying to figure out if your bug is a duplicate of Bug 668275

Thanks.
Status: NEW → ASSIGNED
and i had forgotten the needinfo
Flags: needinfo?(armenzg)
Hi Karl,
The screenshot you show is the basic html gmail. It is the same version I now have.
Before that, did you ever see a page asking you to choose either the basic version versus the full version?

In other word, the very first time you get to gmail you have to choose one of the two versions.
Only one of the two versions can actually be reached (if you choose full version you get prompted forever).

The other indirect issue is that there is no way to get back to the full version once you choose the basic gmail version.
There's no way to switch between the two.

The bugs you mention are not the one I'm mentioning here. Thanks for checking!
Flags: needinfo?(armenzg)
I never had to choose in between two versions. ^_^
I have seen this problem (never ending "are you sure you want to use version x" prompt) - maybe when using a normal Fx Android UA but with Android version number?
(But IMO this is just a side effect of the other GMail backend sniffing problems)
(So IMO this is a dupe of the older bug - 668275)
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668275
This isn't exactly a dupe of bug 668275 - Here, you get a page that allows you to choose, but choosing the full GMail experience redirects you back to the exact same choosing page.

Should we be addressing this separately?
I've marked it dup on the assumption that we're just seeing two symptoms of the backend browser sniffing that prevents us from accessing the full smartphone version. Since the backend browser sniffing requires a complaint to Google I preferred handling these two symptoms in the same complaint..
still valid with firefox mobile 50.0.2
I see simplified and barely useable versions of gmail.com and google.com
Gianni, by firefox mobile, do you mean on Android or Firefox OS? Firefox for Android has been receiving the tier 1 version of Gmail for quite some time.
Flags: needinfo?(giannife)
(In reply to Mike Taylor [:miketaylr] (58 Regression Engineering Owner) from comment #14)
> Gianni, by firefox mobile, do you mean on Android or Firefox OS? Firefox for
> Android has been receiving the tier 1 version of Gmail for quite some time.

On android, sorry for the late reply
Flags: needinfo?(giannife)
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.