Support replaceable homescreen

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: WDM, Assigned: gmarty)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.5+)

Details

(Whiteboard: [systemsfe])

User Story

As a user I want to be able to choose between different homescreens so that I can personlise the look and fell of the device to my own perferences.

AC:

I want to be able to swap between homescreens without having to restart my device
I want to install the new homescreen without resetting the device

IxD Spec Link:
https://drive.google.com/open?id=0B8kj4Mlm-HJeVThwQ0hxWEo5SlU

Attachments

(1 obsolete attachment)

Comment hidden (empty)
(Reporter)

Updated

2 years ago
User Story: (updated)
feature-b2g: --- → 2.5+
Should we close out these bugs in lieu of this one?:
bug 1015213 	[User Story] Download and apply replaceable homescreens
bug 994858 	[Meta] Replaceable Homescreen
I’ve attached a link to the initial IxD spec for replaceable homescreens in the user story section of the bug as well as here:

https://drive.google.com/open?id=0B8kj4Mlm-HJeVThwQ0hxWEo5SlU

This is just an initial draft, so there is more work to do on some of the stories, but feel free to provide any feedback on what is presented so far. Thanks!
User Story: (updated)
(Reporter)

Updated

2 years ago
Blocks: 1186919
Assignee: nobody → chrislord.net
Whiteboard: [systemsfe]

Comment 3

2 years ago
Created attachment 8644930 [details] [review]
[gaia] gmarty:Bug-1180665-Support-replaceable-homescreen > mozilla-b2g:master
(Assignee)

Comment 4

2 years ago
Comment on attachment 8644930 [details] [review]
[gaia] gmarty:Bug-1180665-Support-replaceable-homescreen > mozilla-b2g:master

Let's review this patch in Bug 1180666 instead.
Attachment #8644930 - Attachment is obsolete: true

Updated

2 years ago
Assignee: chrislord.net → gmarty
Depends on: 994858
Duplicate of this bug: 1015213
bug 1180666 landed
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.