"Harness status: OK" + failing test when running "service-worker-csp-script.https.html" test

RESOLVED FIXED in Firefox 44

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: noemi, Unassigned)

Tracking

Trunk
mozilla44
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 affected, firefox44 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Checked with 7/6 master build

Test run such as |./mach web-platform-tests _mozilla/service-workers/service-worker/service-worker-csp-script.https.html|

Result:
* Harness status: OK
* Found 1 test
* 1 Fail:
** CSP test for script-src in ServiceWorkerGlobalScope	
*** assert_unreached: unregister and register should not fail: The expression cannot be converted to return the specified type. Reached unreachable code
unreached_rejection/<@https://web-platform.test:8443/_mozilla/service-workers/service-worker/resources/test-helpers.sub.js?pipe=sub:42:7 Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1363:20 Test.prototype.step_func/<@https://web-platform.test:8443/resources/testharness.js:1387:1 Promise*service_worker_unregister_and_register@https://web-platform.test:8443/_mozilla/service-workers/service-worker/resources/test-helpers.sub.js?pipe=sub:8:10 service_worker_test/<@https://web-platform.test:8443/_mozilla/service-workers/service-worker/resources/test-helpers.sub.js?pipe=sub:146:14 Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1363:20 promise_test@https://web-platform.test:8443/resources/testharness.js:520:25 service_worker_test@https://web-platform.test:8443/_mozilla/service-workers/service-worker/resources/test-helpers.sub.js?pipe=sub:145:1 @https://web-platform.test:8443/_mozilla/service-workers/service-worker/service-worker-csp-script.https.html:7:1 
* Traces: https://pastebin.mozilla.org/8838621
(Reporter)

Comment 1

3 years ago
The same error that running "service-worker-csp-default.https.html" test
(Reporter)

Comment 2

3 years ago
and "service-worker-csp-connect.https.html" test
(Reporter)

Updated

3 years ago
Summary: "Harness status: OK" + failing test when running wpt "service-worker-csp-script.https.html" test → "Harness status: OK" + failing test when running "service-worker-csp-script.https.html" test
(Reporter)

Updated

3 years ago
Component: DOM: Service Workers → web-platform-tests
Product: Core → Testing
See Also: → bug 1187951
Bobby, can you take a look at this test failure? At [1] jdm says: "service-worker-csp-script.https.html - something about script-src, but service-worker-csp-worker.py is missing"

[1]
https://etherpad.mozilla.org/blink-sw-tests
Flags: needinfo?(bobbyholley)
Created attachment 8665133 [details] [diff] [review]
Convert chromium's service-worker-csp-worker.php into server-side python. v1

Here are the missing bits of the test.
The test now times out, because it's expecting a CSP error to be thrown synchronously for the load of a script from the service worker, and we don't do that. Instead, we get an async failure here:

https://pastebin.mozilla.org/8847291

On a higher level though, I'm confused as to why we care about this. My impression was that we were explicitly punting on CSP for the worker itself, and that the spec there had yet to be worked out. Am I missing something?
Flags: needinfo?(bobbyholley) → needinfo?(overholt)
And apparently overholt is out - bkelly, can you comment?
Flags: needinfo?(overholt) → needinfo?(bkelly)
I agree.  I think we can leave this as expected TIMEOUT.

Slightly better, if we could make the script postMessage() back a failure to the document or something so we could FAIL immediately, that would be preferable.
Flags: needinfo?(bkelly)
Created attachment 8668203 [details] [diff] [review]
Convert chromium's service-worker-csp-worker.php into server-side python. v2

I'm not actively working on this, but let's get it in the tree so that it
doesn't get lost.
Attachment #8668203 - Flags: review?(bkelly)
Attachment #8665133 - Attachment is obsolete: true
Attachment #8668203 - Flags: review?(bkelly) → review+
https://hg.mozilla.org/mozilla-central/rev/9b6124d343e8
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
(Reporter)

Comment 13

3 years ago
Hi,

just checked on m-c (5f16c6c2b969 revision) and the test, as expected (please see comment 5), times out.

Summary

Harness status: Timeout

Found 1 tests
1 Timeout
Details
Result	Test Name	Message
Timeout	CSP test for script-src in ServiceWorkerGlobalScope	Test timed out

Updated

3 years ago
Depends on: 1216858
You need to log in before you can comment on or make changes to this bug.