[e10s] Support PageDown and PageUp key event handling (XUL)

RESOLVED INVALID

Status

()

Core
XUL
P4
normal
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: Geoffrey De Belie (Smile4ever), Unassigned)

Tracking

(Blocks: 1 bug)

39 Branch
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150702232110

Steps to reproduce:

This doesn't work (the function does not get called) when e10s is enabled in Firefox Developer 42:

<keyset id="mainKeyset">
	<key id='scrollkey-scrollup-pageup'
	keycode='VK_PAGE_UP'
	oncommand='scrollkey.scrollupif();'
	/>
</keyset>

It does work when e10s is disabled. This code is part of Scrollkey: https://addons.mozilla.org/nl/firefox/addon/scrollkey/

VK_PAGE_DOWN doesn't work either. Something like this works:
<key id='scrollkey-scrolldown-j'
	modifiers=''
	key='j'
	oncommand='scrollkey.scrolldown(0);'
/>
Blocks: 905436
tracking-e10s: --- → +
Status: UNCONFIRMED → NEW
Component: Untriaged → XUL
Ever confirmed: true
Product: Firefox → Core

Updated

a year ago
Priority: -- → P4
This is something that needs to be changed in the add-on code. You'll need a frame script that runs the code that actually does the scrolling, since with e10s enabled you can't invoke functions directly in the content. If you need help doing this, please use one of these: https://developer.mozilla.org/en-US/Add-ons#Contact_us
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.