Remove "about:home" text from showing when clicking on the search bar

RESOLVED DUPLICATE of bug 1038996

Status

()

Firefox for Android
Theme and Visual Design
RESOLVED DUPLICATE of bug 1038996
2 years ago
2 years ago

People

(Reporter: jonalmeida, Assigned: jonalmeida)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
When you click on the search bar 'Search of enter address', we see "about:home" there.

You would expect it to be empty like it was initially when you clicked on the bar (regardless of if we are currently at about:home).
(Assignee)

Updated

2 years ago
Assignee: nobody → jalmeida
Anthony, do you agree with these designs?
Flags: needinfo?(alam)
This is interesting, some questions: 
- what's the user benefit of removing about:home? 
- which state are you describing when you say "initially when you clicked on the bar"? I'm having trouble reproducing it.
Flags: needinfo?(alam) → needinfo?(jalmeida)
(Assignee)

Comment 3

2 years ago
Created attachment 8630778 [details]
about_home_annotated.jpg

> - which state are you describing when you say "initially when you clicked on the bar"? I'm having trouble reproducing it.

Open a new tab, and the URL/Search bar says "Search or enter address". When you click on it, a user would expect an empty text field to type something there, but instead you see "about:home" already there. See the screenshots attached for annotations.

> - what's the user benefit of removing about:home? 
A friend asked me why it was even there in the first place. Every time he clicked on the search bar, it would show "about:home" already there. As a technical user it makes sense, but for the average user it can be confusing.

Note that this is just a minor aesthetic change. The fix would be to remove the contents of the URL/Search field when currently on the about:home page.
Flags: needinfo?(jalmeida) → needinfo?(alam)
(Assignee)

Comment 4

2 years ago
Just realized this also includes private browsing as well to be consistent.
I like this in the l10n context: non-English users are also seeing about:home.

Also, desktop doesn't show the "about:home" text, even if you explicitly go to the page.
I'm open to removing this because it does seem a bit counter intuitive to new users. But I'm going to need some more time to distill some more user value for this move before we commit to it.

Being there, I think that it also has some user value. In particular, it informs the user of a means to get back to their Home Panels. To some (albeit a lesser) extent, it also teaches users that these "address" exist and provides a method that allows our users to talk about this feature. 

Plus, since it highlights by default, it doesn't impede the user experience of typing in the URL bar at all.

Worth noting if we do remove this text, users that just press "go" on the keyboard without typing anything, will see just a blank white page with the keyboard down. We'll want to refresh about:home and keep the keyboard up like we currently do.
Flags: needinfo?(alam)
(In reply to Anthony Lam (:antlam) from comment #6)
> Being there, I think that it also has some user value. In particular, it
> informs the user of a means to get back to their Home Panels.

If they click the url bar, the home panels appear - going to about:home is redundant. Similarly, the new tab button will show the panels. 

> To some
> (albeit a lesser) extent, it also teaches users that these "address" exist

Is this something non-technical users need to know? The addresses are accessible via the menu currently, e.g. about:addons

> and provides a method that allows our users to talk about this feature. 

That's true - there isn't a very good way to categorize the whole group, but I wonder how many people see and register "about:home".
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1038996
You need to log in before you can comment on or make changes to this bug.