Closed Bug 1181081 Opened 7 years ago Closed 1 year ago

urifixup service should correct "http//" or "https//" or "http;//" etc. to insert/replace the colon

Categories

(Core :: DOM: Navigation, defect)

defect
Not set
normal
Points:
2

Tracking

()

RESOLVED FIXED
85 Branch
Iteration:
84.2 - Nov 2 - Nov 15
Tracking Status
firefox42 --- wontfix
firefox85 --- fixed

People

(Reporter: Gijs, Assigned: daisuke)

References

Details

Attachments

(1 file)

Spinning this off from bug 1180460, it is surprising to me that with protocol typo fixup enabled, https//foo gets corrected to http://https//foo.

Reading the code, it makes sense that this happens, but we can + ideally should do better. :-)
See Also: → 1666234
Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Iteration: --- → 84.2 - Nov 2 - Nov 15
Points: --- → 2
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8636b9a39525
Fix up typos for string that user would have intented as protocol. r=mak
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Duplicate of this bug: 1666234
You need to log in before you can comment on or make changes to this bug.