Using Jaws for Windows screen reader and Thunderbird 38.1, I can no longer work with the Jaws cursor: it only reads graphics instead of reading the content of what is on screen.. The same also happens using firefox.

RESOLVED WONTFIX

Status

()

Core
Disability Access APIs
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Angela, Unassigned)

Tracking

(Blocks: 1 bug)

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; .NET4.0C; InfoPath.3; .NET4.0E)

Steps to reproduce:

I tried to work using Jaws cursor to read some content the normal cursor did not catch


Actual results:

It only read the word grapic


Expected results:

It should have rad the the content of the window.

Comment 1

3 years ago
So a regression, i.e. it works in version 31?
Blocks: 617918
Component: Untriaged → Disability Access
Flags: needinfo?(angeladelicata)
Summary: Using Jaws for Windows screen reader and Thunderbird 38.1, I can no longer work with the Jaws cursor: it only reads grapics instead of reading the content of what is on screen.. The same also happens using firefox. → Using Jaws for Windows screen reader and Thunderbird 38.1, I can no longer work with the Jaws cursor: it only reads graphics instead of reading the content of what is on screen.. The same also happens using firefox.

Comment 2

3 years ago
Angela also shared with me...

I find the problem quite annoying because at times, when TB reports an error, I used to read using Jaws cursor to understand what it was going on, now I have to do differently but it is less comfortable for me.
Also using  Braille Display it only works in structured mode and not online mode.
These problems did not happen in previous versions. 


Do we know if similar problems exist with Orca?
(Reporter)

Comment 3

3 years ago
Actually in version 31.0 I had  to set    two configuration variables to true:
gfx.direct2d.disabled and layers.acceleration.disabled. Doing so, it worked fine, but now it doesn't.
Flags: needinfo?(angeladelicata)

Comment 4

3 years ago
(In reply to Angela from comment #3)
> Actually in version 31.0 I had  to set    two configuration variables to
> true:
> gfx.direct2d.disabled and layers.acceleration.disabled. Doing so, it worked
> fine, but now it doesn't.

Please post information about your graphics from Help | Troubleshooting
Do you know if you have the most current version of driver for your graphics?
(Reporter)

Comment 5

3 years ago
Please, guide me on how to accomplish the requested operation... I cannot figure out how to report  grapics trouble shooting...  Using Jaws cursor I can only see some numbers and the word grapic.  Sorry, but I'm not so expert, I wanted to report the bug, but don't know how to explain it better. I have windows 7 32 bits.

Updated

3 years ago
Duplicate of this bug: 1183527

Updated

3 years ago
Component: Disability Access → Disability Access APIs
Product: Thunderbird → Core
Version: 38 → 38 Branch

Comment 7

3 years ago
The old methods for screen scraping JAWS cursor and braille line mode use are no longer compatible with the modern graphics engine in Gecko. Moreover, from Windows 8 onwards, including Windows 10, Microsoft no longer allows graphics driver scraping methods used in JAWS cursor and braille line modes at all. Therefore, it does not make sense for us to maintain backward compatibility with these old methods. JAWS 15 and newer use a new exploration method called Touch Cursor, which also works on computers without touch screens. This method works with Firefox and Thunderbird, too. Please use this for screen exploration from now on. Thank you!

Note that a comparison with Orca is not feasible since Orca never used these screen scraping methods in the first place, and is totally based on proper accessibility APIs. Same is true for NVDA, by the way.


Closing as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

3 years ago
Well, I see: now everything is clear. Thanks so much for reading me and telling me... In fact, I use Jaws 13 I will update then.
You need to log in before you can comment on or make changes to this bug.