Closed Bug 1181351 Opened 5 years ago Closed 3 years ago

[B2G] Some service worker info properties are empty in the list of service workers shown by about:sw for b2g (follow up bug 1174140)

Categories

(Core :: DOM: Service Workers, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
FxOS-S9 (16Oct)
Tracking Status
firefox42 --- affected

People

(Reporter: jaoo, Unassigned)

References

Details

Attachments

(1 file)

Follow up bug 1174140 for B2G.
Assignee: nobody → jaoo
Status: NEW → ASSIGNED
See Also: → 1174140
Target Milestone: --- → FxOS-S2 (10Jul)
Attached patch WIPSplinter Review
In B2G about:sw is chrome process and there is no way to make it content process (like we did for bug 1174140 in desktop). about:sw panel in B2G should work well even being chrome process. The issue here is that some properties don't show up so after following the code I see that the issue is gone by commenting a piece of code. Andrea, could we remove that block?, I don't see the reason of having it.
Attachment #8630768 - Flags: feedback?(amarchesini)
Hi,

Checking Bug 1174140 just landed in m-c, we have realized that a new property called "Push Endpoint" has been added to about:sw properties list so we will dig into it and try to add it in about:sw in b2g within this bug. Thanks!
Summary: [B2G] Some service worker info properties are empty in the list of service workers shown by about:sw (follow up bug 1174140) → [B2G] Some service worker info properties are empty in the list of service workers shown by about:sw for b2g (follow up bug 1174140)
Target Milestone: FxOS-S2 (10Jul) → FxOS-S3 (24Jul)
Hi Catalin,

As commented yesterday during the bi-weekly sync meeting, since SWM refactor will take a while, would you mind to take a look at this bug to see if any kind of workaround could be applied here in the meanwhile?. Thanks!
Depends on: 1182117
Flags: needinfo?(catalin.badea392)
Attachment #8630768 - Flags: feedback?(amarchesini) → feedback?(nsm.nikhil)
Target Milestone: FxOS-S3 (24Jul) → FxOS-S4 (07Aug)
Comment on attachment 8630768 [details] [diff] [review]
WIP

Review of attachment 8630768 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry this took time. The problem with allowing this to go through is that the active worker ServiceWorkerInfo's URL will change under any actual WorkerPrivate instance running for the ServiceWorkerInfo.
Attachment #8630768 - Flags: feedback?(nsm.nikhil) → feedback-
Target Milestone: FxOS-S4 (07Aug) → FxOS-S5 (21Aug)
Target Milestone: FxOS-S5 (21Aug) → ---
(In reply to Nikhil Marathe [:nsm] (please needinfo?) from comment #4)
> Comment on attachment 8630768 [details] [diff] [review]
> WIP
> 
> Review of attachment 8630768 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Sorry this took time. The problem with allowing this to go through is that
> the active worker ServiceWorkerInfo's URL will change under any actual
> WorkerPrivate instance running for the ServiceWorkerInfo.

Thanks for your feedback. I've been trying to figure out another different fix for this but honestly I'm out of ideas. Could you share what you might have in mind for a fix here please? Maybe It's not worth to work on this until bug 1182117 get fixed? Thanks.
Flags: needinfo?(nsm.nikhil)
If you want to update the active URL, then yes, you'll have to wait. This state mirroring was always going to be a stop-gap at the best.
Flags: needinfo?(nsm.nikhil)
Assignee: jaoo → nobody
Status: ASSIGNED → NEW
Target Milestone: --- → FxOS-S7 (18Sep)
Target Milestone: FxOS-S7 (18Sep) → FxOS-S8 (02Oct)
Target Milestone: FxOS-S8 (02Oct) → FxOS-S9 (16Oct)
Flags: needinfo?(catalin.badea392)
No longer depends on: 1182117
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.