[Gallery] In Edit Mode, toggling 'Auto-Enhance' then tapping the 'X' in top left will do nothing

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Gallery
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: oliverthor, Assigned: pdahiya)

Tracking

({regression})

unspecified
FxOS-S4 (07Aug)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing], [Spark], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Description:
If the user is editing an image in their gallery and they tap the 'Auto-Enhance' wand button (far right icon), they may observe that attempting to exit afterwards by tapping the 'X', without tapping other 'Edit' buttons, will have no effect. Tapping the 'X' a second time, from this point, will then close the edit view.

PreReq:
* have an image in gallery
Repro Steps:
1) Update a Aries to 20150707033152
2) Open gallery
3) Tap on image
4) Tap 'Edit' button
5) Tap 'Auto-Enhance' wand button (far-right).
6) Tap 'X'

Actual:
Edit view is not closed, tapping 'X' again will close

Expected:
Edit view is closed


Environmental Variables:
-----------------------------

Device: Aries 2.5
Build ID: 20150707033152
Gaia: e6506d68e01489b57616f8b74e8773f938ce62b3
Gecko: e271ef4c49ae
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
BuildID: 20150707010204
Gaia: e6506d68e01489b57616f8b74e8773f938ce62b3
Gecko: e7e69cc8c07b
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.2
BuildID: 20150707002504
Gaia: ea11f422b687a982f0a961c9aea7858066561707
Gecko: 52d19a805d35
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
********************

Issue DOES NOT REPRODUCE on 2.1 for flame devices
Reslts: Tapping 'Auto-Enhance' then tapping 'X' will close the edit view

Device: Flame 2.1
BuildID: 20150707001206
Gaia: d13826b20b4a45e3f5cd4b25a30a737d8be7f1b9
Gecko: 37de99064c33
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------

Repro frequency: 5/5
See attached: 
video: will upload link tomorrow, youtube is disagreeing with me
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Comment 1

3 years ago
Created attachment 8631299 [details]
logcat_20150708_1522.txt
Small regression, NI on component owner for nomination decision and assignment.
Blocks: 1171119
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(npark)
Keywords: regression
[Blocking Requested - why for this release]:

I think it's worth blocking, since it's quite a common use case and obvious regression.
blocking-b2g: --- → 2.5?
Flags: needinfo?(npark)
(Assignee)

Updated

3 years ago
Assignee: nobody → pdahiya
(Assignee)

Comment 5

3 years ago
Taking bug to investigate and submit fix
(Assignee)

Comment 6

3 years ago
Investigated and this issue is regression caused by refactoring image editing as two steps process (Bug 1087494), Auto enhance edit tool is single step and stays on main edit screen. 

For Auto enhance, Cancel event handler on first cancel tap has currentEditTool set to 'enhance' and that's why not exiting main edit screen without saving edited image.

https://github.com/mozilla-b2g/gaia/blob/master/apps/gallery/js/ImageEditor.js#L553

I will submit patch to update cancel event handler for enhance to exit from main edit screen on first tap.
Created attachment 8636692 [details] [review]
[gaia] punamdahiya:Bug1181371 > mozilla-b2g:master
(Assignee)

Comment 8

3 years ago
Comment on attachment 8636692 [details] [review]
[gaia] punamdahiya:Bug1181371 > mozilla-b2g:master

Hi David

Attaching patch that on Cancel checks for enhance as currentEditTool and exit main edit screen. Please review. Thanks!
Attachment #8636692 - Flags: review?(dflanagan)

Comment 9

3 years ago
Blocking Reason: regression
blocking-b2g: 2.5? → 2.5+
Comment on attachment 8636692 [details] [review]
[gaia] punamdahiya:Bug1181371 > mozilla-b2g:master

I didn't test, but this looks good to me.
Attachment #8636692 - Flags: review?(dflanagan) → review+
Should we have automated testing for this? Sounds like a good candidate.
(In reply to Hubert Figuiere [:hub] from comment #11)
> Should we have automated testing for this? Sounds like a good candidate.

I think so too, I'll put it in my todo list, and hopefully get on it this quarter, unless someone else can work on it beforehand.
(Assignee)

Comment 13

3 years ago
Thanks Hub for feedback. I will update patch with test relevant to this fix. 

No-Jun, It will be very helpful if we can have similar test for all edit tool flows which can be landed as a separate bug. Thank you so much for your help with the tests!
(Assignee)

Comment 14

3 years ago
Comment on attachment 8636692 [details] [review]
[gaia] punamdahiya:Bug1181371 > mozilla-b2g:master

Hi No-Jun

Asking for your review of tests in updated patch as you are familiar with gallery marionette tests. Thanks!
Attachment #8636692 - Flags: review?(npark)
Comment on attachment 8636692 [details] [review]
[gaia] punamdahiya:Bug1181371 > mozilla-b2g:master

Ran it locally and LGTM.
Attachment #8636692 - Flags: review?(npark) → review+
(Assignee)

Comment 16

3 years ago
Thanks No-Jun and David for review. Patch landed on master

https://github.com/mozilla-b2g/gaia/commit/b34683f9a46dcd9d47ff51174b17917510eda05b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Target Milestone: --- → FxOS-S4 (07Aug)
This issue is verified fixed on Flame and Aries. Following STR, tapping on X correctly closes the edit mode window.

Device: Aries 2.5
BuildID: 20150804120650
Gaia: 67c38af8347f93ddc005a53f427d651b744b55c1
Gecko: 5cf4d2f7f2f2
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
BuildID: 20150804030213
Gaia: caba8b26c52d3c771e9ea6fe288acdaf74c7707e
Gecko: 5b54831761b1
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.