All users were logged out of Bugzilla on October 13th, 2018

image aligned too high - not fully visible inside browser window

RESOLVED DUPLICATE of bug 118501

Status

()

RESOLVED DUPLICATE of bug 118501
17 years ago
17 years ago

People

(Reporter: chayes, Assigned: dbaron)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

17 years ago
A gif is aligned too high, so only the bottom half is visible. The top half is
not inside the browser window.
Seen at: the logo in top left corner of www.bolster.nl (uses frames).

Same behavior in Netscape 6.2 (windows).

Gif shown entirely in Netscape 4.7 (win) and IE6 (win).



------ html details -----
frame-indexpage (index.html):
 no doctype declaration
  <FRAMESET COLS="140,*" ROWS="*" FRAMEBORDER=0 BORDER=0> 
  <FRAME SRC="menu.html" NAME="menu"        SCROLLING="AUTO" 
         MARGINWIDTH="3" MARGINHEIGHT="1"  FRAMEBORDER=0    BORDER=0>

framepage (menu.html):
  metatag <META HTTP-EQUIV="Content-Type" 
                CONTENT="text/html; charset=iso-8859-1">
  the image part:
  <BODY [...] >
  <P><A HREF="opening.html" TARGET="inhoud"><BR><IMG SRC="bolster_menu.gif"
WIDTH="120" HEIGHT="100" BORDER="0" ALT="Terug naar de startpagina"></A><BR>
</P>
<TABLE BORDER="0" CELLSPACING="0" CELLPADDING="2">

Comment 1

17 years ago
Confirming issue in the Jan 3rd build (2002-01-03-08).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Created attachment 63564 [details]
Reduced test case of problem.

Problem is caused by the following css rule:

a {vertical-align: top}

The image is contained in this A element which uses the vertical alignment
property/value.
Created attachment 66937 [details]
Enhancement of previous testcase

Note the borders set on the (newly added) 'p' and 'span' elements.  These show
that the elements are all being laid out as one would expect, except for one
thing.	The anchor element is not as tall as the image-- doesn't actually
shrinkwrap it, in other words.	Opera has the same interpretation, but IE does
not.  I'm sure this falls out of a pure reading of the CSS2 layout model, but
here's at elast one example of the problems that causes for us.
Attachment #63564 - Attachment is obsolete: true
Created attachment 66946 [details]
Enhanced enhanced testcase

Here's a better version of the test with one paragraph containing a top-aligned
anchor, and another with an anchor that has no vertical alignment at all.  Then
I have the same two paragraphs again, except reversed, so the top-align-anchor
paragraph comes second in the latter pair.
Attachment #66937 - Attachment is obsolete: true

Comment 5

17 years ago
I think this really falls more along the style system. David/Ian if that is an 
incorrect, please reassign back to Marc.

The odd thing that I noticed, especially with Eric's test cases, is that the 
anchor frame did not fully encase the image, which seems odd to me.

Also, if I set the vertical-align to the image then the desired behavior is 
displayed : reporter, you may want to try that as a means to getting the effect 
that you want
Assignee: attinasi → dbaron
Component: Layout → Style System
QA Contact: petersen → ian
This is a layout bug, but it's a duplicate of a bug that I think Ian filed
saying that we should redo our top/bottom to work as I proposed (although it's
still being discussed in the WG).  I think according to the current spec this is
correct behavior.
Component: Style System → Layout

*** This bug has been marked as a duplicate of 118501 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.