Browser becomes unresponsive pending content reload on application state change

RESOLVED DUPLICATE of bug 1191585

Status

()

Firefox for iOS
General
RESOLVED DUPLICATE of bug 1191585
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: sleroux)

Tracking

unspecified
ARM
iOS

Firefox Tracking Flags

(fxios1.1+)

Details

(Reporter)

Description

3 years ago
From https://groups.google.com/a/mozilla.com/forum/?utm_medium=email&utm_source=footer#!msg/ios-feedback/TmKq0D8NFb8/W_0PO8bU0yEJ

On execution state change of the app we force a reload (why?), during this time the application is unresponsive until that is complete.
(Reporter)

Updated

3 years ago
Summary: Browser becomes unresponsive pending content reload on state change → Browser becomes unresponsive pending content reload on application state change

Updated

3 years ago
tracking-fxios: ? → +
(Assignee)

Comment 1

3 years ago
We shouldn't be reloading the page whenever opening the app the the browser view controller appears. For example, if we're offline we want to be able to see the previous loaded page without it trying to reload it. 

As far as the delay, I think this is happening from when the app gets terminated in the background and needs a full relaunch.
(Assignee)

Updated

3 years ago
Assignee: nobody → sleroux
(Assignee)

Comment 2

3 years ago
Running the app and looking at the code, this behavior doesn't happen whenever we're coming back into the app while we're backgrounded. If the app is killed in the background and requires a cold start, a cached screenshot of the app is displayed, which make the app look unresponsive, and the web page reloads. Note that this is similar behavior to Chrome. The only difference is that instead of displaying a cached screenshot on cold boot, they show a 'empty' version of the browser view which then transitions into the greyed out version actual web view to indicate it's stale/still loading.

I think to fix this, we might need to work on the perception of what the user sees from a cold boot. Thoughts?
Flags: needinfo?(dhenein)
tracking-fxios: + → ---
(Assignee)

Comment 3

3 years ago
Won't block 1.0 - clearing tracking flag
tracking-fxios: --- → +
(Assignee)

Updated

3 years ago
tracking-fxios: + → ---
(Reporter)

Comment 4

3 years ago
From a quality standpoint we should track this post 1.0
tracking-fxios: --- → ?
tracking-fxios: ? → 1.1+
Flags: needinfo?(dhenein)
(Assignee)

Comment 5

3 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=1191585 will be the solution for this bug. Closing as dupe.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1191585
You need to log in before you can comment on or make changes to this bug.