[EME] GMPGetAPI wrongly logs an error when decryptor API is requested

RESOLVED FIXED in Firefox 42

Status

()

--
minor
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gerald, Assigned: gerald)

Tracking

(Blocks: 1 bug)

unspecified
mozilla42
x86
Windows
Points:
---

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
A missing 'else' in GMPGetAPI is the cause:
  if ( decryptor? ) {...}
  if ( audio decoder? ) {...}  <-- missing 'else'
  else if ( ... ) {...}
  else { log error }

Logging is only enabled by modifying some source and recompiling, so it's minor.
(Assignee)

Comment 1

3 years ago
Created attachment 8631930 [details] [diff] [review]
1182363-add-missing-else.patch

Added missing 'else' to prevent wrong error logging on Windows.
Attachment #8631930 - Flags: review?(edwin)
https://hg.mozilla.org/mozilla-central/rev/2e42de2a4643
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.